Last dietpi on Orange pi Plus 2e

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
LuPoX
Posts: 19
Joined: Wed Dec 14, 2016 4:52 pm

Last dietpi on Orange pi Plus 2e

Post by LuPoX »

Hello, first of all, if this topic does not go here, I'm sorry, move it where appropriate.
I'm trying to install dietpi in an Orange Pi Plus 2e following this manual: https://github.com/Fourdee/DietPi/issue ... -280771944 but when it comes time to select the version of orange pi that I have, mine does not appear, I am installing it in Debian, and I have also tried with raspbian, I have tried with Generic device, Orange Pi Plus and Orange Pi PC Plus both with jessie, streetch and buster and I always get this error:



Code: Select all

Ign:1 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie InRelease
Ign:2 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie Release
Ign:3 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main all Packages
Ign:4 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main armhf Packages
Ign:5 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main Translation-en_GB
Ign:8 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main Translation-en
Ign:3 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main all Packages
Ign:4 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main armhf Packages
Ign:5 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main Translation-en_GB
Ign:8 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main Translation-en
Ign:3 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main all Packages
Ign:4 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main armhf Packages
Ign:6 https://cdn-aws.deb.debian.org/debian stretch InRelease
Ign:5 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main Translation-en_GB
Ign:8 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main Translation-en
Ign:3 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main all Packages
Hit:7 https://cdn-aws.deb.debian.org/debian stretch-updates InRelease
Hit:9 https://cdn-aws.deb.debian.org/debian-security stretch/updates InRelease
Ign:4 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main armhf Packages
Ign:5 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main Translation-en_GB
Hit:10 https://cdn-aws.deb.debian.org/debian stretch-backports InRelease
Ign:8 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main Translation-en
Hit:11 https://cdn-aws.deb.debian.org/debian stretch Release
Ign:3 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main all Packages
Ign:4 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main armhf Packages
Ign:5 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main Translation-en_GB
Ign:8 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main Translation-en
Ign:3 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main all Packages
Err:4 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main armhf Packages
  404  Not Found
Ign:5 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main Translation-en_GB
Ign:8 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie/main Translation-en
Reading package lists...
W: The repository 'http://ppa.launchpad.net/nowrep/qupzilla/ubuntu jessie Release' does not have a Release file.
E: Failed to fetch http://ppa.launchpad.net/nowrep/qupzilla/ubuntu/dists/jessie/main/binary-armhf/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

[FAILED] DietPi-PREP | G_AGUP
Can anyone help me, i was ussing last releasy for orange pi plus2 make for this team but now im trying to update to last version but cant :/
LuPoX
Posts: 19
Joined: Wed Dec 14, 2016 4:52 pm

Re: Last dietpi on Orange pi Plus 2e

Post by LuPoX »

Finally i use armbian server version and works all, but now i have a problem, every time i restart, date change to 2016 and cant install nothing, need to change every time the date

FIXED WITH THIS :
Fourdee wrote: Tue May 23, 2017 1:02 pm Hi,

Firstly, make sure you are running DietPi v150, as we fixed a known problem where NTPD wouldnt start in some cases.

Failing that, switch to SystemD-Timesync:
dietpi-config > advanced > time sync mode > 4 Daemon + Drift
LuPoX
Posts: 19
Joined: Wed Dec 14, 2016 4:52 pm

Re: Last dietpi on Orange pi Plus 2e

Post by LuPoX »

I have again the same problem, when sistem restart, date sets on 1977, and now i cant change this:
Failing that, switch to SystemD-Timesync:
dietpi-config > advanced > time sync mode > 4 Daemon + Drift
because i cant change the data :

Code: Select all

root@DietPi:~# date
lun sep  5 04:43:40 CEST 1977
root@DietPi:~# date --set "2018-08-22 18:48"
date: no se puede establecer la fecha: Argumento inválido
mié ago 22 18:48:00 CEST 2018
root@DietPi:~# date
lun sep  5 04:43:59 CEST 1977
Some help please
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Last dietpi on Orange pi Plus 2e

Post by Fourdee »

Hi,

Could be an issue with hwclock detection. Please paste results:

Code: Select all

hwclock
dpkg -l | grep hwclock
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
baz123
Posts: 166
Joined: Thu Jan 12, 2017 9:23 pm

Re: Last dietpi on Orange pi Plus 2e

Post by baz123 »

I found I needed to use the following command to force sync

Code: Select all

sntp -s time.google.com
I did a write up on what I found on a pi https://tech.borpin.co.uk/2018/05/18/ke ... e-on-a-pi/

What I should add it that if the time difference is too great it will not sync without the -s flag (AIUI).
LuPoX
Posts: 19
Joined: Wed Dec 14, 2016 4:52 pm

Re: Last dietpi on Orange pi Plus 2e

Post by LuPoX »

i dont know how but after a reboot, i can change time again and now works fine :S
Post Reply