[Solved] Unable to mount External HDD NTFS

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
GnobarEl
Posts: 11
Joined: Thu Aug 09, 2018 5:31 pm

[Solved] Unable to mount External HDD NTFS

Post by GnobarEl »

Hello guys!

I'm have some issues loading my external HDD (1TB).

I'm making the following steps:

Code: Select all

sudo fdisk -l

Code: Select all

Device      Start        End    Sectors   Size Type
/dev/sda1      34     262177     262144   128M Microsoft reserved
/dev/sda2  264192 1953523711 1953259520 931,4G Microsoft basic data

Code: Select all

sudo mount -t ntfs /dev/sda2 /mnt/piHDD
ERROR:

Code: Select all

modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/4.14.59-v7+/modules.dep.bin'
modprobe: FATAL: Module fuse not found in directory /lib/modules/4.14.59-v7+
ntfs-3g-mount: fuse device is missing, try 'modprobe fuse' as root
I've already tried other steps, but the error is always the same. Any idea?

Thanks.

Best Regards,
Last edited by GnobarEl on Thu Aug 09, 2018 7:12 pm, edited 1 time in total.
GnobarEl
Posts: 11
Joined: Thu Aug 09, 2018 5:31 pm

Re: Unable to mount External HDD NTFS

Post by GnobarEl »

I found this command

Code: Select all

dietpi-drive_manager
but the result is the same :(
Error.png
GnobarEl
Posts: 11
Joined: Thu Aug 09, 2018 5:31 pm

Re: Unable to mount External HDD NTFS

Post by GnobarEl »

Hi all,

after some digging I found the solution.

Don't know why but the folder /lib/modules/4.14.59-v7+ is empty. Thats why I was getting that error.

I downloaded the correct files and copy to the folder. Voila! Working.

Downloaded the files from here:

Code: Select all

https://github.com/raspberrypi/firmware/tree/1b51c69e77c995a2da223948ab3844db177704af/modules/4.14.59-v7%2B
Thanks to everyone.
Nohippychicks
Posts: 11
Joined: Fri May 04, 2018 3:15 am

Re: [Solved] Unable to mount External HDD NTFS

Post by Nohippychicks »

The error you got while trying to mount the drive is different than mine, but I'm having trouble getting a mounted drive to show. When I saw this post, I didn't think it was the same issue I was having, but when I looked at the 4.14.52-v7+, I also found it to be empty so maybe this is my solution as well.

I have a couple of questions, though: Can you show me what you read that lead you to check that? It's not something I really even knew to look at.

Second, did you just download every single thing at the link you gave, put it on a USB drive and move it over with command prompts?
GnobarEl
Posts: 11
Joined: Thu Aug 09, 2018 5:31 pm

Re: [Solved] Unable to mount External HDD NTFS

Post by GnobarEl »

Hello,

my comments inline:
Nohippychicks wrote: Thu Aug 09, 2018 9:08 pm The error you got while trying to mount the drive is different than mine, but I'm having trouble getting a mounted drive to show. When I saw this post, I didn't think it was the same issue I was having, but when I looked at the 4.14.52-v7+, I also found it to be empty so maybe this is my solution as well.

I have a couple of questions, though: Can you show me what you read that lead you to check that? It's not something I really even knew to look at.

[GbobarEl] the error was this:

Code: Select all

modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/4.14.59-v7+/modules.dep.bin'
modprobe: FATAL: Module fuse not found in directory /lib/modules/4.14.59-v7+
it was pointing to that folder, and that make me look into it.

Second, did you just download every single thing at the link you gave, put it on a USB drive and move it over with command prompts?

[GbobarEl]
Yes, I download the zip file, extracted the folder and upload it by FTP
Post Reply