Radarr service failed, but launches manually

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
camjc
Posts: 1
Joined: Mon Aug 06, 2018 11:12 am

Radarr service failed, but launches manually

Post by camjc »

When I run

Code: Select all

dietpi-services status
I get

Code: Select all

[FAILED] DietPi-Services | radarr	failed (Result: exit-code) since Mon 2018-08-06 09:57:45 BST; 30min ago
● radarr.service - Radarr Daemon
   Loaded: loaded (/etc/systemd/system/radarr.service; disabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2018-08-06 09:57:45 BST; 30min ago
  Process: 902 ExecStart=/usr/bin/mono /opt/Radarr/Radarr.exe -nobrowser -data=/mnt/dietpi_userdata/radarr (code=exited, status=1/FAILURE)
 Main PID: 902 (code=exited, status=1/FAILURE)

Aug 06 09:57:44 DietPi mono[902]:   at NzbDrone.Core.Datastore.DbFactory.RegisterDatabase (NzbDrone.Common.Composition.IContainer container) [0x00006] in <d622740c3f6a4ed084b707bca6d9b562>:0
Aug 06 09:57:44 DietPi mono[902]:   at Radarr.Host.NzbDroneServiceFactory.Start () [0x00012] in <995dab1107b24482ba8bf8963e3706e7>:0
Aug 06 09:57:44 DietPi mono[902]:   at Radarr.Host.Router.Route (Radarr.Host.ApplicationModes applicationModes) [0x00067] in <995dab1107b24482ba8bf8963e3706e7>:0
Aug 06 09:57:44 DietPi mono[902]:   at Radarr.Host.Bootstrap.Start (Radarr.Host.ApplicationModes applicationModes, NzbDrone.Common.EnvironmentInfo.StartupContext startupContext) [0x00047] in <995dab1107b24482ba8bf8963e3706e7>:0
Aug 06 09:57:44 DietPi mono[902]:   at Radarr.Host.Bootstrap.Start (NzbDrone.Common.EnvironmentInfo.StartupContext startupContext, Radarr.Host.IUserAlert userAlert, System.Action`1[T] startCallback) [0x00075] in <995dab1107b24482ba8bf8963e3706e7>:0
Aug 06 09:57:44 DietPi mono[902]:   at NzbDrone.Console.ConsoleApp.Main (System.String[] args) [0x0002f] in <b6e6e83031db400582b8bc076d3bc359>:0
But if I just run

Code: Select all

/usr/bin/mono /opt/Radarr/Radarr.exe -nobrowser -data=/mnt/dietpi_userdata/radarr
it works fine.

I'm not sure what the differences are between me running that command myself, and dietpi services running that same command.

Can someone please let me know what I could try to fix it so that I don't have to manually run this command every time?

Thanks!
- Cam
User avatar
MichaIng
Site Admin
Posts: 2422
Joined: Sat Nov 18, 2017 6:21 pm

Re: Radarr service failed, but launches manually

Post by MichaIng »

@camjc
Thanks for your report.

Could you please show the full error output (systemctl status radarr just shows the tail):
systemctl start radarr, then
journalctl -t mono
or journalctl -u mono
or if this does not work just journalctl

In the latter case you will have full journal log, thus scroll to the bottom via <space> and copy all the lines at the end that are related to mono/radarr.
Post Reply