Sonarr randomly crashing after new install

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
sfishe
Posts: 8
Joined: Wed Jul 25, 2018 9:02 am

Sonarr randomly crashing after new install

Post by sfishe »

After a fresh dietpi install on an Odroid XU4 recently, Sonarr will randomly crash. It will work fine for a few hours or so, and then the service will fail. Here is the output from 'dietpi-services status':

Code: Select all

[FAILED] DietPi-Services | sonarr	failed (Result: signal) since Wed 2018-07-25 16:59:01 AEST; 50s ago
● sonarr.service - Sonarr (NzbDrone) Daemon
   Loaded: loaded (/etc/systemd/system/sonarr.service; disabled; vendor preset: enabled)
   Active: failed (Result: signal) since Wed 2018-07-25 16:59:01 AEST; 50s ago
  Process: 1147 ExecStart=/usr/bin/mono /opt/NzbDrone/NzbDrone.exe -nobrowser -data=/mnt/dietpi_userdata/sonarr (code=killed, signal=ABRT)
 Main PID: 1147 (code=killed, signal=ABRT)

Jul 25 16:59:01 DietPi mono[1147]: ad91b000-ad934000 r-xp 00000000 b3:02 33044      /lib/arm-linux-gnueabihf/liblzma.so.5.2.2
Jul 25 16:59:01 DietPi mono[1147]: ad934000-ad943000 ---p 00019000 b3:02 33044      /lib/arm-linux-gnueabihf/liblzma.so.5.2.2
Jul 25 16:59:01 DietPi mono[1147]: ad943000-ad944000 r-xp 00018000 b3:02 33044      /lib/arm-linux-gnueabihf/liblzma.so.5.2.2
Jul 25 16:59:01 DietPi mono[1147]: ad944000-ad945000 rwxp 00019000 b3:02 33044      /lib/arm-linux-gnueabihf/liblzma.so.5.2.2
Jul 25 16:59:01 DietPi mono[1147]: ad945000-ad94f000 r-xp 00000000 b3:02 3734       /usr/lib/arm-linux-gnueabihf/libXext.so.6.4.0
Jul 25 16:59:01 DietPi mono[1147]: ad94f000-ad95e000 ---p 0000a000 b3:02 3734       /usr/lib/arm-linux-gnueabihf/libXext.so.6.4.0
Jul 25 16:59:01 DietPi mono[1147]: ad95e000-ad95f000 r-xp 00009000 b3:02 3734       /usr/lib/arm-linux-gnueabihf/libXext.so.6.4.0
Jul 25 16:59:01 DietPi systemd[1]: sonarr.service: Main process exited, code=killed, status=6/ABRT
Jul 25 16:59:01 DietPi systemd[1]: sonarr.service: Unit entered failed state.
Jul 25 16:59:01 DietPi systemd[1]: sonarr.service: Failed with result 'signal'.

Any ideas?
M4RT1NJB
Posts: 1
Joined: Sat Jul 28, 2018 1:29 pm

Re: Sonarr randomly crashing after new install

Post by M4RT1NJB »

I have the same issue after 'upgrading' from a Raspberry Pi 3 to an Odroid XU4. I had it working from a fresh install about 8 days ago, and was configuring Sonarr and Radarr remotely using Remot3.it. I then noticed that I was unable to write to my NAS (Apple TimeCapsule) when attempting a bulk import, then while trying to troubleshoot that, this problem began. The dietpi installation on RPi using the same fstab entry has worked flawlessly, so it looks like I'll have to use the RPi for Sonarr and Radarr until this is fixed. I've since re-imaged the eMMC from the default IMG, but have the same Sonarr and Radarr issue.

There is a related post which refers to issues posted on Github, but it seems this is still not fixed.
viewtopic.php?f=11&t=2913&hilit=sonarr
Post Reply