[Solved] problems!!

Having issues with your DietPi installation, or, found a bug? Post it here.
rndm
Posts: 1
Joined: Sat Jan 11, 2020 12:28 pm

Re: [Solved] problems!!

Post by rndm »

Hi,

I'm using Dietpi for Nextcloud and tried to add my USB HDD.
After the last reboot i have the problem, that the globals are missing and i can not connect through ssh.

I can download the Repair Files and unpack it, but the Rest of it doesn't work:

rm update.zip (file or directory missing)
cp -Rf /tmp/DietPi-master/rootfs/. / (missing,too)
sync
rm -R /tmp/DietPi-master
chmod -R +x /DietPi /etc/cron.*/dietpi /var/lib/dietpi/services
systemctl daemon-reload

I'm not a linux user, but i tried my best that everything is running. That was the first damn mistake after the cloud was running perfectly. I just wanted to add some more space.

Any help before i reinstall the complete system from the beginning?
User avatar
Joulinar
Posts: 2085
Joined: Sat Nov 16, 2019 12:49 am

Re: [Solved] problems!!

Post by Joulinar »

to get SSH back running, you could try to reinstall dropbear SSH server. I assume it was the SSH server used as it's the default one.

Code: Select all

dietpi-software reinstall 104
But it might be better to start with a clean installation as we don't know what else is missing from the system.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 2295
Joined: Sat Nov 18, 2017 6:21 pm

Re: [Solved] problems!!

Post by MichaIng »

@rndm
Most likely the files are not missing, but DietPi-RAMdisk didn't start successfully. Could you please paste the result of those commands:

Code: Select all

journalctl -u boot.mount
journalctl -u DietPi.mount
journalctl -u dietpi-ramdisk
cat /var/tmp/dietpi/logs/dietpi-ramdisk.log
If you attached a USB HDD, is it a desktop PC or an SBC (like RPi) you tried this on? In case of SBC, please note that external drives MUST have a dedicated power supply, else under-voltage will happen earlier or later, crashing the system, leading to SDcard corruption in cases.
Post Reply