Unable to access on lan

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Sabiracer
Posts: 31
Joined: Thu Jan 25, 2018 1:36 pm

Unable to access on lan

Post by Sabiracer »

Hi all, Sorry to bother you guys but i'm having some issues lately.
At the moment i have DietPi on my Raspberry Pi 2 connected to my router with an ethernet cable. I have several shares available and can access these from my phone via Wifi.
The issue is that from ANY PC that i connect via ethernet i can't even ping the IP.

As a test i took my laptop (an HP Elite X2) and connected it to wired connection... no reply from hostname or IP.
As soon as i disconnected the ethernet and went onto Wifi i could ping IP and hostname and browse the shares.

I have disabled the Windows firewall with no change. Can anyone help me out?

The reply i get is Destination host unreachable. this is when i ping IP or i get unable to resolve using hostname.
Sabiracer
Posts: 31
Joined: Thu Jan 25, 2018 1:36 pm

Re: Unable to access on lan

Post by Sabiracer »

Anyone?
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: Unable to access on lan

Post by johnvick »

I'm no expert but I suspect your router config is at fault - are wired and wireless devices on the same subnet (usually 255.255.255.0)?

John
User avatar
WarHawk
Posts: 606
Joined: Thu Jul 20, 2017 8:55 am

Re: Unable to access on lan

Post by WarHawk »

Have you logged into your router and looked to see if it has a different assigned dhcp address?
Sabiracer
Posts: 31
Joined: Thu Jan 25, 2018 1:36 pm

Re: Unable to access on lan

Post by Sabiracer »

All on same subnet and IP addresses all seem correct.
I'm just trying a fresh install of DietPi, and if that fails i think it's a good excuse for a new router :-)
User avatar
WarHawk
Posts: 606
Joined: Thu Jul 20, 2017 8:55 am

Re: Unable to access on lan

Post by WarHawk »

Is your home router set up for network isolation...aka LAN cannot talk to WLAN and vice versa?

What router and model are you running?
Sabiracer
Posts: 31
Joined: Thu Jan 25, 2018 1:36 pm

Re: Unable to access on lan

Post by Sabiracer »

Thanks for the replies, It is a TP-LINK TL-WR841N with DDWRT installed.
I couldnt see any isolation settings and had been working fine previously. I have just flashed a fresh image of 6.10 dietpi onto my pi2 so will test it out tonight.
Post Reply