SD card partially dead after rpi-update

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Superboy
Posts: 2
Joined: Tue Jun 12, 2018 3:20 am

SD card partially dead after rpi-update

Post by Superboy »

Hello!
Thanks for the brilliant distro, it's so quick and the built-in dietpi-* utilities are so convenient!

I had a working DietPi installation on a Pi 3B+, but after running rpi-update the Pi would no longer boot, nothing at all over HDMI.

I removed and attempted to backup the SD card with dd, but during this I kept getting I/O errors. I assumed the SD card was dying. I recovered some data after running disktool and other recovery utilities, and low-level erased the SD card with the SD formatter from sdcard.org. It however seemed to be fine after this, so I proceeded to reinstall DietPi on the same card. I set it up and it was running fine for a few days, and I then did rpi-update again. After a reboot, black screen. Trying to access the SD card with my Mac resulted in I/O errors again. I realise rpi-update is maintained upstream but I was interested to see if anyone has had this same problem or knew of a solution without reinstalling again?

Thanks!
User avatar
MichaIng
Site Admin
Posts: 2281
Joined: Sat Nov 18, 2017 6:21 pm

Re: SD card partially dead after rpi-update

Post by MichaIng »

Hmm my SD card was failing as well after rpi-update to 4.14.48.
Kernel was not able to mount root, external fsck found several errors.

It thought is was due to SD card bad blocks, but might be related to firmware/kernel bug as well. Currently I am on stable APT package again without issues.

rpi-update to master branch indeed is not considered to be stable, thus should just be done for dev or if specific error you face was fixed with it.
Superboy
Posts: 2
Joined: Tue Jun 12, 2018 3:20 am

Re: SD card partially dead after rpi-update

Post by Superboy »

Interesting! I think I'll post a bug report upstream. I do like to keep on the bleeding edge so I do expect problems, though this seemed quite a biggie.

As I've written in my report, its curious that the card seems to work fine with an ancient USB reader, but with the built-in (PCIe) reader on two different Macs it gets IO errors. Perhaps something to do with the read speed or a base set of commands vs the newer SDXC stuff.

Reported here
User avatar
MichaIng
Site Admin
Posts: 2281
Joined: Sat Nov 18, 2017 6:21 pm

Re: SD card partially dead after rpi-update

Post by MichaIng »

Indeed the error should be verified on a proven flawless SDcard and at best on fresh Raspbian Lite.

But let's see, maybe there are already more users experiencing this on different systems.
Post Reply