[Solved] v6.9 help with Samba and more

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
Edward
Posts: 93
Joined: Sun Apr 09, 2017 6:24 am

[Solved] v6.9 help with Samba and more

Post by Edward »

Seems that Samba client has a host of dependencies that can not be resolved.

Is the repo list up to date or complete?

Also is it possible to toggle on/off the update Dietpi thing....If possible I'd like to go back to v6.8 or earlier and be able to update and install etc. without having to update Dietpi
Edward
Posts: 93
Joined: Sun Apr 09, 2017 6:24 am

Re: v6.9 help with Samba and more

Post by Edward »

It appears v6.9 is Debian "Buster"....FYI as far as I know Buster is still very upstream and not yet released.

Hence all the problems trying to install and remove things....O!MPD problems too.

I think you guys jumped the gun and were a little bit over anxious on this release....v6.9 is not ready for prime time.

IMO 8)
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: v6.9 help with Samba and more

Post by johnvick »

Why do you think it is Buster?

I have just upgraded to 6.9 and the Debian version here is 9.4 - Stretch.

John
Edward
Posts: 93
Joined: Sun Apr 09, 2017 6:24 am

Re: v6.9 help with Samba and more

Post by Edward »

Just guessing from this error message.....see below...

[ OK ] DietPi-Software | APT autoremove + purge, please wait...
/DietPi/dietpi/func/dietpi-globals: line 1459: apt-get: command not found

[FAILED] DietPi-Software | G_AGA
[ INFO ] DietPi-Software | If problems persist, please report this to DietPi for investigation


--------------------------------------------------------------------
- DietPi has encounted an error, and, is unable to continue -
- Please create a ticket: https://github.com/Fourdee/DietPi/issues -
- Copy and paste the BLUE lines below, into the ticket -
--------------------------------------------------------------------


#### Details:
- Date | Sat 9 Jun 19:03:59 BST 2018
- BR sent? | 0 : 2760a474-a539-4677-8373-31a0af7f2c42
- DietPi version | v6.9
- Img creator | n/a
- Pre-image | n/a
- SBC device | Sparky SBC (armv7l) (index=70)
- Distro | buster (index=5)
- Command | G_AGA
- Exit code | 127
- Software title | DietPi-Software

#### Expected behaviour:
<!-- What SHOULD be happening? -->

#### Actual behaviour:
<!-- What IS happening? -->

#### Steps to reproduce:
<!-- Explain how to reproduce the issue -->

#### Additional Information:
<!-- if applicable -->

#### Additional logs:
```
Log file contents:
/DietPi/dietpi/func/dietpi-globals: line 1459: apt-get: command not found
```


--------------------------------------------------------------------

[FAILED] DietPi-Software | Unable to continue, DietPi-Software will now terminate.
Edward
Posts: 93
Joined: Sun Apr 09, 2017 6:24 am

Re: v6.9 help with Samba and more

Post by Edward »

johnvick wrote: Sat Jun 09, 2018 9:16 pm Why do you think it is Buster?

I have just upgraded to 6.9 and the Debian version here is 9.4 - Stretch.

John
root@DietPi:~# cat /etc/debian_version
buster/sid
root@DietPi:~#
Edward
Posts: 93
Joined: Sun Apr 09, 2017 6:24 am

Re: v6.9 help with Samba and more

Post by Edward »

Other strange stuff is Logitech Media Server gets stuck on the install.

Trying to install it manually shows that it needs a perl package installed first. Even after installing the dependency it still freezes during install.
User avatar
MichaIng
Site Admin
Posts: 2294
Joined: Sat Nov 18, 2017 6:21 pm

Re: v6.9 help with Samba and more

Post by MichaIng »

@Edward
That is strange. DietPi updates do not change anything about the underlying Debian version and we do not offer any Buster image.

How did you install DietPi? If you used our preparation script, then you can choose between Jessie, Stretch and Buster, but it is clearly stated, that Buster is in testing phase and Stretch is the recommended distro version. €: As I state below, the system was upgraded (partly?) to sid repo, which is not possible via DietPi-PREP.

/DietPi/dietpi/func/dietpi-globals: line 1459: apt-get: command not found
This doesn't sound like a regular Debian either. My testing Raspbian and Debian Buster (x86_64) systems both support apt-get (autoremove) command.

Okay I checked your bug report:
  • Your /etc/debian_version (which we scan to estimate distro version) indeed shows buster/sid, the underlying APT package base-files is at v10.1, which is only available on buster and sid.
  • I checked your repo: Currently your APT repo is Stretch, as it should be, but there is one commented sid line. This is something we would never add, so I guess you experimented with this or chose a pre-image, that is based on experiments.
  • The buster repo of Debian is quite stable (not Raspbian!! just Debian ;) ), but the sid repo is as the same indicates: A crash testing battleground. Do never (!) switch to sid, if you don't want to help debugging packages before they are integrated into testing (buster).
  • The APT version itself is at some sid-only beta version. Maybe they experiment there with completely removing the apt-get command in favour of simply apt.
  • So yeah it's a difficult task to cleanly revert a system back to a previous Debian version, if not impossible, as there are system core packages affected. I hope you have a backup in place in case?
Edward
Posts: 93
Joined: Sun Apr 09, 2017 6:24 am

Re: v6.9 help with Samba and more

Post by Edward »

@ MichaIng

Yes that was strange. I did a in using dietpi-update, on version 6.8 I did install a application from the Buster repo. But as far as I know, doing this won't completely upgrade or change your distro.

I ended up just flashing a new image, no worries. After that it just updated itself to version 6.9 and everything was back to normal.
User avatar
MichaIng
Site Admin
Posts: 2294
Joined: Sat Nov 18, 2017 6:21 pm

Re: v6.9 help with Samba and more

Post by MichaIng »

@Edward
Yeah, installing even just one APT package from Buster repo can bring with it a rat's tail of dependency package upgrades down to core packages. Always be careful when trying this and check which/how much packages are affected. As always do a dietpi-backup first ;).

Btw. as said, never use unstable (sid) or experimental repo, instead testing (buster) as latest one, which already went through much testing before. Buster generally can be seen as stable as "stable" (stretch) repo, just with a high APT package upgrade rate, which also includes major version upgrades (e.g. PHP7.0 => PHP7.1 => PHP7.2), which always bears a risk and could lead to manual needed adjustment steps (PHP: Adjust e.g. Apache PHP module, upgrade/port PHP7.0 config files over to /etc/php/7.2/..., adjust enabled/disabled modules etc.).

But to avoid all this dependency rat's tail, better use "stretch-backports" repo instead of buster. It contains many version updates from buster, but with core dependencies from stretch repo or in case included within the backports repo. But it is aimed and well tested to work with stretch of course. Generally if a package update is not contained within the backports repo, it simply might not work stable enough there as a reason.
Edward
Posts: 93
Joined: Sun Apr 09, 2017 6:24 am

Re: [Solved] v6.9 help with Samba and more

Post by Edward »

Okay great, thank you for the information and the follow up....

:D
Post Reply