Trouble with Airsonic

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
rothchild
Posts: 79
Joined: Sat Jun 27, 2015 10:39 am

Trouble with Airsonic

Post by rothchild »

Hi there,

I finally got to running upgrades on my various SBC to make the leao to the new version of DP. All in done pretty well, the Model B Pi with pihole was very straightforward, the NanoPi Neo with Subsonic 6 tool a little bit of prodding but is now mostly up and running but I took the opportunity to try out Airsonic on a Pi 2 and I'm getting error when I try and start it (with 'service airsonic restart')

● airsonic.service - Airsonic Media Server
Loaded: loaded (/etc/systemd/system/airsonic.service; disabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Mon 2018-04-23 22:09:37 BST; 4min 58s ago
Process: 1236 ExecStart=/usr/bin/java -Xmx195m -Dairsonic.home=/mnt/dietpi_userdata/airsonic -Dserver.context-path=/airsonic -Dserver.port
=8080 -jar /mnt/dietpi_userdata/airsonic/airsonic.war (code=exited, status=1/FAILURE)
Main PID: 1236 (code=exited, status=1/FAILURE)

Apr 23 22:09:37 MoreChild java[1236]: ... 35 common frames omitted
Apr 23 22:09:37 MoreChild java[1236]: Caused by: java.lang.ClassNotFoundException: javax.xml.bind.JAXBException
Apr 23 22:09:37 MoreChild java[1236]: at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:466) ~[na:na]
Apr 23 22:09:37 MoreChild java[1236]: at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:563) ~[na:na]
Apr 23 22:09:37 MoreChild java[1236]: at org.springframework.boot.loader.LaunchedURLClassLoader.loadClass(LaunchedURLClassLoader.jav
a:94) ~[airsonic.war:10.1.1-RELEASE]
Apr 23 22:09:37 MoreChild java[1236]: at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:496) ~[na:na]
Apr 23 22:09:37 MoreChild java[1236]: ... 37 common frames omitted
Apr 23 22:09:37 MoreChild systemd[1]: airsonic.service: Main process exited, code=exited, status=1/FAILURE
Apr 23 22:09:37 MoreChild systemd[1]: airsonic.service: Unit entered failed state.
Apr 23 22:09:37 MoreChild systemd[1]: airsonic.service: Failed with result 'exit-code'.


Apparently it's a java problem but I'm at something of a loss as to where to start to fix it, any tips?
rothchild
Posts: 79
Joined: Sat Jun 27, 2015 10:39 am

Re: Trouble with Airsonic

Post by rothchild »

Hmm,

Not sure if there might not be a broader issue here?

I gave up on Airsonic and tried to install Subsonic, all appeared ok, I can see it running in HTOP, but when I try to log in I get the old '503' corrupt database error, so I went to /var/subsonic to delete the db file and it's not there!

I thought maybe there was a conflict with Airsonic so did a re-image and fresh install but again Subsonic doesn't create all the neccesary db files in /var/subsonic

It's working fine on my nanopi neo.

Not sure where to go from here, any tips gratefully received.
rothchild
Posts: 79
Joined: Sat Jun 27, 2015 10:39 am

Re: Trouble with Airsonic

Post by rothchild »

Definite Java issues with the Pi image

Code: Select all

Error: missing `server' JVM at `/usr/lib/jvm/java-8-openjdk-armhf/jre/lib/arm/server/libjvm.so'.
Please install or use the JRE or JDK that contains these missing components.
E: /etc/ca-certificates/update.d/jks-keystore exited with code 1.
done.
Errors were encountered while processing:
 ca-certificates-java
 openjdk-8-jre-headless:armhf
 openjdk-8-jdk-headless:armhf
 openjdk-8-jdk:armhf
 openjdk-8-jre:armhf
E: Sub-process /usr/bin/dpkg returned an error code (1)
ShaneC80
Posts: 5
Joined: Wed May 09, 2018 4:41 pm

Re: Trouble with Airsonic

Post by ShaneC80 »

Is there a solution for this? I can't seem to get Subonic to work. Same deal with the 503 unavailible and missing files.

edit: I'm on a Pi3

going to poke around Airsonic and give it a shot. Right now i'm getting a "refused to connect" - but I've not done much with it yet, so I may have borked it or missed something simple
rothchild
Posts: 79
Joined: Sat Jun 27, 2015 10:39 am

Re: Trouble with Airsonic

Post by rothchild »

Thanks Shane, glad it's not just me!

Look forward to hearing how you get on - Subsonic is running great on my Nano Pi Neo (apart from issues with the usb audio) but there's still no joy on the Pi for now.
ShaneC80
Posts: 5
Joined: Wed May 09, 2018 4:41 pm

Re: Trouble with Airsonic

Post by ShaneC80 »

I don't claim to know what I'm doing, but this worked for me:

Code: Select all

sudo su
echo "deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main" | tee /etc/apt/sources.list.d/webupd8team-java.list
apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys EEA14886

apt-get update
apt-get install oracle-java8-installer
stolen from https://www.raspberrypi.org/forums/view ... p?t=101543
rothchild
Posts: 79
Joined: Sat Jun 27, 2015 10:39 am

Re: Trouble with Airsonic

Post by rothchild »

Thanks Shane,

Alas, still no dice with Subsonic on my Pi.
Post Reply