[SOLVED] Trouble rebooting with WIFI AP from dietpi-software

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
skyfly555
Posts: 81
Joined: Tue Nov 17, 2015 12:16 pm

[SOLVED] Trouble rebooting with WIFI AP from dietpi-software

Post by skyfly555 »

Hi,

I've installed WIFI Hotspot on a TP-LINK TL-WN722N v2, with the driver provided by MrEngMan.

Code: Select all

wget http://fars-robotics.net/install-wifi -O /usr/bin/install-wifi
chmod +x /usr/bin/install-wifi
sudo install-wifi
The trouble I'm facing is:
- When I reboot, I need to:
a) Disconnect the wifi dongle;
b) Wait for some seconds:
c) Connect the wifi dongle again.
I see when I type iwconfig:

Code: Select all

wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
d) service hostapd restart
I see when I type iwconfig:

Code: Select all

wlan0     IEEE 802.11bg  ESSID:"My_WIFI"  Nickname:"<WIFI@REALTEK>"
          Mode:Master  Frequency:2.422 GHz  Access Point: 7C:8B:CA:13:AB:D5   
          Bit Rate:54 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
To be able to connect to the WIFI Hotspot.

Can this be solved?
I have all the config set as it's supposed to be (allow hotplug, etc.).

For example, /etc/network/interfaces:

Code: Select all

#/etc/network/interfaces
#Please use DietPi-Config to modify network settings.

# Local
auto lo
iface lo inet loopback

# Ethernet
allow-hotplug eth0
iface eth0 inet static
address 192.168.0.11
netmask 255.255.255.0
gateway 192.168.0.1
dns-nameservers 192.168.0.10

# Wifi
allow-hotplug wlan0
iface wlan0 inet static
address 192.168.42.1
netmask 255.255.255.0
#gateway 192.168.0.1
wireless-power on
dns-nameservers 8.8.8.8 8.8.4.4

# IP tables
up iptables-restore < /etc/iptables.ipv4.nat
Last edited by skyfly555 on Tue Apr 03, 2018 5:56 pm, edited 3 times in total.
skyfly555
Posts: 81
Joined: Tue Nov 17, 2015 12:16 pm

Re: Trouble rebooting with WIFI HotSpot from dietpi-software

Post by skyfly555 »

Ups! I forgot it: using an RPi2, DietPi v6.4 Stretch.
skyfly555
Posts: 81
Joined: Tue Nov 17, 2015 12:16 pm

Re: Trouble rebooting with WIFI HotSpot from dietpi-software

Post by skyfly555 »

Weird! It boots OK, sorry, but it needs like 3 minutes to boot!

So, I thought it was not working, because of the inusual loooooog time to boot.

Although... do you know how to get Bit Rate:150 Mb/s instead of Bit Rate:54 Mb/s???
skyfly555
Posts: 81
Joined: Tue Nov 17, 2015 12:16 pm

Re: Trouble rebooting with WIFI HotSpot from dietpi-software

Post by skyfly555 »

I have checked with an EDIMAX N150 and I get the same results.
skyfly555
Posts: 81
Joined: Tue Nov 17, 2015 12:16 pm

Re: Trouble rebooting with WIFI HotSpot from dietpi-software

Post by skyfly555 »

Solved the speed issue, adding these two lines to /etc/hostapd/hostapd.conf:

Code: Select all

ieee80211n=1
wmm_enabled=1
I don't need to reconnect the wifi dongle, just be patient, because it needs 2-3 minutes to boot, strange for me, it usually boots much faster, it seem hostapd needs time to boot :)
Last edited by skyfly555 on Tue Apr 03, 2018 2:08 pm, edited 1 time in total.
Joseph_Lin
Posts: 22
Joined: Tue Sep 26, 2017 2:56 am

Re: Trouble rebooting with WIFI HotSpot from dietpi-software

Post by Joseph_Lin »

Yeah, I have the same problem. I thought it did not work until one time I forgot to check if it is turned on for several minutes and found my cellphone did connect to the hotspot! It needs 3 minutes to work!
Post Reply