Docker not working with external HDD

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
yogeen
Posts: 1
Joined: Sat Mar 10, 2018 9:19 pm

Docker not working with external HDD

Post by yogeen »

Hello guys
I have just installed this wonderful system on my Raspberry Pi3 and also setup it that it uses external HDD. Until that moment all worked great and was very easy. Then I installed two software tools from the DietPi list - Docker and Webadmin. Well I installed more but these do not work.
I do not care much about Webadmin but Docker was the reason I started with DietPi, so I really want it working.
The installation went all fine and also docker status seems to be working. However when I try to actually download any image I always get the same error in the end.
docker: failed to register layer: symlink and now long path pointing to docker folder on the HDD: operation not permitted
Anyone had similar issue or may possibly know the cause.
Thanks in advance for your help
User avatar
WarHawk
Posts: 631
Joined: Thu Jul 20, 2017 8:55 am

Re: Docker not working with external HDD

Post by WarHawk »

dietpi-drive_manager

get to it from dietpi-launcher...
Post Reply