DietPi Emby server can´t connect to shared folder

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
fezon
Posts: 3
Joined: Fri Mar 02, 2018 10:59 am

DietPi Emby server can´t connect to shared folder

Post by fezon »

Hi,

I have just installed DiepPi to run a Emby server. on a Pi3. My media-HDD is attached to my ASUS router via samba share.

In the library section in Emby - I cannot see the shared folders under "Network"

Image

Please, can anybody describe for me what´s wrong. This is my first experience with dietpi.

Thanks
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: DietPi Emby server can´t connect to shared folder

Post by johnvick »

Is the media drive listed in /etc/fstab?

If not you'll need to do this before Emby will see the drive.

John
mattrixk
Posts: 2
Joined: Fri Apr 13, 2018 6:45 am

Re: DietPi Emby server can´t connect to shared folder

Post by mattrixk »

johnvick wrote:Is the media drive listed in /etc/fstab?

If not you'll need to do this before Emby will see the drive.
I'm having the same issue, but I'm new to DietPi. Can you please tell me how to do this, or point me at the correct articles?

I'm also having the issue that all images and nfo files are downloading as 0KB. I don't know if that's related. If not, then I'll start a separate thread.
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: DietPi Emby server can´t connect to shared folder

Post by johnvick »

How is your media drive connected to the device running Emby?
mattrixk
Posts: 2
Joined: Fri Apr 13, 2018 6:45 am

Re: DietPi Emby server can´t connect to shared folder

Post by mattrixk »

I have a WD 3TB MyCloud NAS drive connected to my modem/router via ethernet cable, and my Raspberry Pi 3B with DietPi and Emby Server also connected to the modem/router via ethernet cable (I followed these instructions https://www.smarthomebeginner.com/setup ... erry-pi-3/).

I was able to access my NAS drive by entering "\\xxx.xxx.x.x\movies\" into the library section (the image the OP posted), and now it says the file path is "smb://xxx.xxx.x.x/movies".

BecauseI could point to the right folder, the server was able to download images and metadata ("save artwork and metadata into media folders" set to true), and I can see them in my browser (http://192.168.0.15:8096/web/movies.html..), but when I look at the image and nfo files next to the movie files, they are all 0KB. I have no idea why the images and nfo files are empty, but still show up in the library.

I don't know if this is a DietPi issue, or an Emby issue, but I have Emby running fine on my PC, so I thought I'd try here for help first.
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: DietPi Emby server can´t connect to shared folder

Post by johnvick »

Have you got the NAS drive mounted in /etc/fstab?

For example:

//192.168.1.4/Movies /mnt/Movies cifs credentials=/root/.smbcreds,x-systemd.automount 0 0

Where /root/.smbcreds is a text file containing the username and password to access the NAS.

Possibly Emby may not have write permission on the folder your media is in?

John
Post Reply