Odroid C2 / Dietpi 6.2 / Pihole (broken)

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
repomanz
Posts: 4
Joined: Thu Jun 23, 2016 2:08 am

Odroid C2 / Dietpi 6.2 / Pihole (broken)

Post by repomanz »

Hi everyone.

I typically keep my dietpi updated and such and knew that I had to reflash an image to get to 6.2. However now that I'm at 6.2 I've discovered that there isn't a pihole offering in the software section and it appears there's issues with latest dietpi / jesse branches, dnsmasq and the latest pihole and it was purposely removed.

Not necessarily asking for a date here; just curious what the dietpi team is planning on handling this issue so I can determine what to do next. This device i'm using had one fantastic job across my network and it worked well. run an awesome OS like dietpi and pihole.

Is there any workarounds to this issue by staying on dietpi 6.2 and the latest pihole? I saw that there was a dnsmasq update package but it was for RP3 and wrong architecture. We have dnsmasq base and dnsmasq 2.76 deb files for our odroid platform somewhere?

JJ
User avatar
k-plan
Posts: 416
Joined: Sun Feb 28, 2016 5:28 pm

Re: Odroid C2 / Dietpi 6.2 / Pihole (broken)

Post by k-plan »

Hi,
repomanz wrote:just curious what the dietpi team is planning on handling this issue so I can determine what to do next.
Hmm ... what we can do? At the moment, sadly nothing. Pi-Hole issue is not at our end.
Fourdee has reported the problem to DL6ER : https://github.com/pi-hole/pi-hole/comm ... 9ea180acde

But we started the next review, to get Odroid device, based on Debian Jessie maintained by meverik, up to Debian Stretch: https://github.com/Fourdee/DietPi/issues/1552

Is there any workarounds to this issue by staying on dietpi 6.2 and the latest pihole?

- If the latest pihole version is must have, you can update to Debian Stretch.
But you will lose e.g. Kodi, GPU/VPU support and get unknown (untested) software support by dietpi-software


- If you had a working Pi-Hole installation with DietPi v6.1, now updated to DietPi v6.2 and updated to Pi-hole Version v3.3 | Web Interface Version v3.3 | FTL Version v3.0 , you can try this: Re: Pihole no longer in optimized software
But you will end up with: Pi-hole Version v3.2.1 | Web Interface Version v3.2.1 | FTL Version v2.13.2


- If you are on DietPi v6.2 without Pi-Hole, you can comment out or use a older version of dietpi-software.
When install Pi-Hole via dietpi-software and repair/downgrade like as above to Pi-hole Version v3.2.1 | Web Interface Version v3.2.1 | FTL Version v2.13.2


- If you are on DietPi v6.2 without Pi-Hole, you can install Pi-Hole via their own web install scripte, and now repair/downgrade like as above to Pi-hole Version v3.2.1 | Web Interface Version v3.2.1 | FTL Version v2.13.2
But you will loose all option to install software via dietpi-software , which need a web server stack.


- If you have a working backup for you device from a previous version , you can play it back and stay on it, until a working fix is available from Pi-Hole for Jessie.

Sorry. Don't see any different option at the moment.

repomanz wrote:We have dnsmasq base and dnsmasq 2.76 deb files for our odroid platform somewhere?
You can try to compile it from source, I simple can not do it (individual disability).
Missing compiling option is: inotify

http://dietpi.com/phpbb/viewtopic.php?f ... 888#p11107

To get it clear:
Fourdee wrote:As our work is focused outside of kernel or OS development (its not what we do), we are only ...
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.
Post Reply