Apache2 Trouble on NanoPi Neo Plus Dietpi v6.1

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Joseph_Lin
Posts: 22
Joined: Tue Sep 26, 2017 2:56 am

Apache2 Trouble on NanoPi Neo Plus Dietpi v6.1

Post by Joseph_Lin »

My owncloud for some reason no longer able to sync with my client so I decided to move on to Dietpi v6 and it went well. The only problem is that I cannot browse Nanopi's webpage even though Apache2 in installed. I can browse to Plex Media Server but port 80 is not reachable. Port 443 is not reachable neither. Can someone help me?
Thanks
Joseph_Lin
Posts: 22
Joined: Tue Sep 26, 2017 2:56 am

Re: Apache2 Trouble on NanoPi Neo Plus Dietpi v6.1

Post by Joseph_Lin »

I tried Lighttpd and it works. There must be something wrong with Apache2
Joseph_Lin
Posts: 22
Joined: Tue Sep 26, 2017 2:56 am

Re: Apache2 Trouble on NanoPi Neo Plus Dietpi v6.1

Post by Joseph_Lin »

I also found php7.0-fpm cannot start, I cannot run owncloud of nextcloud without php!
Please help!
Attachments
Capture.JPG
Joseph_Lin
Posts: 22
Joined: Tue Sep 26, 2017 2:56 am

Re: Apache2 Trouble on NanoPi Neo Plus Dietpi v6.1

Post by Joseph_Lin »

Found the cause of Php, when both owncloud and nextcloud are installed, php will not start! Maybe I am supposed to install one of the cloud?
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: Apache2 Trouble on NanoPi Neo Plus Dietpi v6.1

Post by Fourdee »

Joseph_Lin wrote:Found the cause of Php, when both owncloud and nextcloud are installed, php will not start! Maybe I am supposed to install one of the cloud?
Yep, please only install one, we do not support dual configuration/operation of both these titles at the same time.

Best bet is to uninstall both, then reinstall the one you require.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
MichaIng
Site Admin
Posts: 2295
Joined: Sat Nov 18, 2017 6:21 pm

Re: Apache2 Trouble on NanoPi Neo Plus Dietpi v6.1

Post by MichaIng »

Actually it should be possible to install both. This was the case during many of my testing installations. But I will try/investigate again, especially with Lighttpd.

As long as I am not at home for testing: Could you paste the contents of:
- /etc/php/7.0/mods-available/apcu.ini
- /etc/php/7.0/mods-available/opcache.ini
- and output of: systemctl status php7.0-fpm
Post Reply