RPi-Kodi won't start if using OpenGL mode thru dietpi-config

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
gpioneer
Posts: 9
Joined: Sun Dec 24, 2017 11:27 am

RPi-Kodi won't start if using OpenGL mode thru dietpi-config

Post by gpioneer »

This is with Raspberry Pi 3, using latest DietPi image, over HDMI to my Sony TV:
using dietpi-config and display options, if I choose plain 1920x1080, Kodi starts. If I use OpenGL 1920x1080 option, Kodi does not start.

Code: Select all

Segmentation fault (core dumped)
Crash report available at /root/kodi_crashlog-20171224_043521.log
[E] Failed to power on HDMI with explicit settings (CEA mode 16)
User avatar
k-plan
Posts: 416
Joined: Sun Feb 28, 2016 5:28 pm

Re: RPi-Kodi won't start if using OpenGL mode thru dietpi-co

Post by k-plan »

Kodi will only function if you are using the Broadcom drivers! This is the "Original non-GL desktop driver" , which is currently the default on the Raspbian based images. If you select the open-source OpenGL driver, it won't work!

Kodi on Raspbian requires a minimum of 160 MB of RAM dedicated to the GPU to function properly! ("Memory Split")
If you have a RPi 2/3, the recommended is 256 MB of RAM for the GPU.
Source: https://www.raspberrypi.org/forums/view ... p?t=192499
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.
gpioneer
Posts: 9
Joined: Sun Dec 24, 2017 11:27 am

Re: RPi-Kodi won't start if using OpenGL mode thru dietpi-co

Post by gpioneer »

k-plan wrote:
Kodi will only function if you are using the Broadcom drivers! This is the "Original non-GL desktop driver" , which is currently the default on the Raspbian based images. If you select the open-source OpenGL driver, it won't work!

Kodi on Raspbian requires a minimum of 160 MB of RAM dedicated to the GPU to function properly! ("Memory Split")
If you have a RPi 2/3, the recommended is 256 MB of RAM for the GPU.
Source: https://www.raspberrypi.org/forums/view ... p?t=192499
Ahh, OK. Sheesh, I spent a much time googeling last night and troubleshooting but did not run into this!

I figured using the OpenGL option would improve performance for Kodi.

Thank you for the info!!
Post Reply