SSH NOT working after 158/159 update

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
jarjargeek
Posts: 3
Joined: Wed Mar 08, 2017 1:18 pm

SSH NOT working after 158/159 update

Post by jarjargeek »

Not logged on remotely for a while after I updated to 158 - can NOT login via SSH anymore ?? Tried updating to 159 but still does NOT work; 'Bad Credentials' or 'Permission Denied' . Running a RaspberryPi 3B / Stretch / Nginx DietPi setup. Please beware I'm fairly n00bish in some of these tech matters. :D
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: SSH NOT working after 158/159 update

Post by Fourdee »

jarjargeek wrote:Not logged on remotely for a while after I updated to 158 - can NOT login via SSH anymore ?? Tried updating to 159 but still does NOT work; 'Bad Credentials' or 'Permission Denied' . Running a RaspberryPi 3B / Stretch / Nginx DietPi setup. Please beware I'm fairly n00bish in some of these tech matters. :D
Hi,

Thanks for the report.

We've not changed anything specific in relation to SSH servers during patching.

Can you confirm the following:
- User attempting to login (eg: pi)
- Have you changed the system password in dietpi-config or other means?
- PSU used (eg: official RPi 5v/2.5A
- SD card used
- SSH server installed (if you have not changed this in dietpi-software choice selection, it will be dropbear)
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
jarjargeek
Posts: 3
Joined: Wed Mar 08, 2017 1:18 pm

Re: SSH NOT working after 158/159 update

Post by jarjargeek »

well as I'm running it as a blog/webserver (headless) I've not had to tinker much with it BUT I changed password IMMEDIATELY after a mild panic when I tried to SSH into it. Hooked it up to screen - everything else working OK , blog running fine and VNC works as well. I have it hardwired to the router BTW. OHH I'm running it off a Sandisk 32Gb USB stick but as said had NO issues so far. Used OpenSSH from DietPi software install initially - should I try to remove and reinstall ??
NTwoO
Posts: 15
Joined: Wed May 03, 2017 9:53 pm

Re: SSH NOT working after 158/159 update

Post by NTwoO »

My SSH also failed. I posted the output of a login in another thread.
Post Reply