Emby-server

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Emby-server

Post by johnvick »

Hi Fourdee,

I have run into problems with Emby crashing which their forum admin thinks is due to me running Mono v 5.4 - they only support up to v 4.8.1.

I have updated Mono with apt-get update without thinking too much about it which is no doubt why I have ended up with this version.

Just tried to install Emby on a spare device and I see it uses Mono 4.8.1 - how can I prevent apt-get update from offering updates to this version?

John
User avatar
Fourdee
Site Admin
Posts: 2782
Joined: Tue Feb 06, 2007 1:36 pm

Re: Emby-server

Post by Fourdee »

Hi John,

If you remove the mono repo from system, should prevent it overwriting during apt-get upgrades

Code: Select all

rm /etc/apt/sources.list.d/mono-xamarin.list
apt-get clean
apt-get update
Another option is to hold the packages:

Code: Select all

apt-mark hold PACKAGENAME
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
k-plan
Posts: 416
Joined: Sun Feb 28, 2016 5:28 pm

Re: Emby-server

Post by k-plan »

Hi John,
Fourdee wrote:Another option is to hold the packages:
or :

Code: Select all

echo "<package-name> hold" |  dpkg --set-selections
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: Emby-server

Post by johnvick »

Thanks guys.
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: Emby-server

Post by johnvick »

Big problems here. I have uninstalled Emby and removed Mono using these instructions:

https://askubuntu.com/questions/644938/ ... emove-mono

Mono appears to have gone as mono -V produces no response.

Reinstalling Emby pulls in Mono v 5.4 not the 4.8.1 version I need and Emby keeps crashing.

Any ideas how to fix this - preferably just by removing/replacing Mono and keeping Emby to avoid having to rebuild its database?

John
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: Emby-server

Post by johnvick »

Finally seem to have fixed this but it was a pig of a job.

Uninstall emby-server

Remove all traces of mono 5.4 https://askubuntu.com/questions/644938/ ... emove-mono

In /etc/apt/sources.list.d changed mono.xamarin.list to contain this line:
deb http://download.mono-project.com/repo/debian wheezy/snapshots/4.8.1.0 main

Therefore locking in this version of mono.

In /etc/apt/sources.list.d in emby-server.list have this line:
deb http://download.opensuse.org/repositori ... ntu_14.04/ /

apt-get update

apt-get install mono-devel=4.8.1.0-0xamarin1 (possibly an unnecessary step)

Installed two missing components of Emby https://emby.media/community/index.php? ... it-sticky/

apt-get install emby-server (had to do this manually as the dietpi-software way didn't work, possibly due to undetected mono 5.4 files left over?).

All good! Spent hours on this and a couple of sleepless nights.
All because I somehow updated mono - no fault of dietpi here.

John
Post Reply