Go Lang - old version on current DietPi release

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
elton
Posts: 9
Joined: Thu Nov 02, 2017 7:28 am

Go Lang - old version on current DietPi release

Post by elton »

Ran into Go Lang requirement twice in 24 hours.

Latest DietPi does ships with GoLang in repo. Issue is it is version 1.3.xx. Everything I tried seems to have requirements of 1.5 or newer release.

Anyone have a GoLang how-to source or otherwise install for DietPi that currently works? I RTFM'd their GoLang official documentation on source compile and just isn't resonating in the chicken and egg how-to. Better doc needed for humans for sure (that's where DietPi fills a real big niche).
elton
Posts: 9
Joined: Thu Nov 02, 2017 7:28 am

Re: Go Lang - old version on current DietPi release

Post by elton »

My fix (on the Odroid XU4) for this which may be inefficient was to:

1. Uninstall the golang version shipped in the OS.

2. Download the ARM6 golang binary from their website.

3. Follow the docs on placement of the archive files.

Golang this way appears to work on the Odroid XU4. Using it now even though the XU4 is an ARM 7 CPU and the binary bundle there is for ARM 6.
Post Reply