Using streamer and xawtv to capture video from webcam

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
diggy_dude
Posts: 10
Joined: Sat Oct 01, 2016 4:41 pm

Using streamer and xawtv to capture video from webcam

Post by diggy_dude »

streamer is a webcam capture program that is either bundled with xawtv or can be installed separately if not included with the package for your distro. I can capture JPEG stills from the webcam just fine. But when I try to capture an AVI video from the webcam, I get the message:

oss: open /dev/dsp: No such file or directory
movie writer initialisation failed

Is there something else I need to install or configure to make it work?

Thanks!
Jim
diggy_dude
Posts: 10
Joined: Sat Oct 01, 2016 4:41 pm

Re: Using streamer and xawtv to capture video from webcam

Post by diggy_dude »

I tried installing oss-compat and osspd. Neither of these solved the missing dsp directory issue.
diggy_dude
Posts: 10
Joined: Sat Oct 01, 2016 4:41 pm

Re: Using streamer and xawtv to capture video from webcam

Post by diggy_dude »

It captures video without sound when I remove the command line argument for audio format. Since my ancient Logitech webcam probably doesn't have a microphone, this is, as they say, "good enough for government work." Thanks!
User avatar
WarHawk
Posts: 608
Joined: Thu Jul 20, 2017 8:55 am

Re: Using streamer and xawtv to capture video from webcam

Post by WarHawk »

What directory and file did you edit, show us your config file so others that might have this problem can learn from your work

:)
Post Reply