ProFTP problem

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
von

ProFTP problem

Post by von »

After installing proftp on my rpi3 I can't connect to the pi. The ssh doesn't work (connection refused error), pihole doesn't work.
Currently I don't have any hdmi cable so can't tell what's going on. Anyone know what's the problem?
User avatar
k-plan
Posts: 416
Joined: Sun Feb 28, 2016 5:28 pm

Re: ProFTP problem

Post by k-plan »

can you "ping" ip address of your RPi3 ?
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.
von

Re: ProFTP problem

Post by von »

So here is what happened after connecting to the monitor.
emergency-mode.jpg
Tried reboot few times and still got same result. So I tried "systemctl reboot", "systemctl default" all same emergency mode. Then I tried "journalctl -xb" to what's causing this error and got this.
whole-bunch-of-theyse-messages.jpg

Code: Select all

vc_vchi_sm_init: failed to open VCHI service (-1)
[vc_sm_connected_init] failed to initialize shared memory service
and also I got failed mount error because I disconnected my drives. So I disabled auto mount from "/etc/fstab" and tried again and it worked. I've uninstalled the proftp and everythings back to the where it was.

TLDR; should I install samba instead of proftp?
Post Reply