Using camera fails

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
dietpiOK
Posts: 79
Joined: Thu Mar 16, 2017 9:33 am

Using camera fails

Post by dietpiOK »

Hi,

for a couple of months my camera on the raspi was working properly. But since a couple of days I am seeing this error when using raspistill

Code: Select all

root@schuppi:~# raspistill -v
mmalipc: mmal_vc_init_fd: could not open vchiq service
mmal: mmal_vc_component_create: failed to initialise mmal ipc for 'vc.camera_info' (7:EIO)
mmal: mmal_component_create_core: could not create component 'vc.camera_info' (7)
mmal: Failed to create camera_info component
I already applied the following commands:

Code: Select all

Usermod -a G video olaf
and

Code: Select all

Chmod 666 /dev/vchiq

Unfortunately the error is still there :(

Any idea?

Regards,
Olaf
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Using camera fails

Post by Fourdee »

Hi,

Could be a camera failure, happened to me once. Power off and re-check ribbon + sunny connections are flush.
Image

Failing that, just double check GPU memory split is 128MB (dietpi-config > display options)
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
dietpiOK
Posts: 79
Joined: Thu Mar 16, 2017 9:33 am

Re: Using camera fails

Post by dietpiOK »

Hi,

a reboot and checking all wires solved that issue... strange...

Best regards,
Olaf
Post Reply