v151 flooding twi_start()434 - [i2c0] START can't sendout!

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
jake
Posts: 10
Joined: Mon Feb 27, 2017 1:58 am

v151 flooding twi_start()434 - [i2c0] START can't sendout!

Post by jake »

All of a sudden /var/log on my NanoPi NEO is filling up with a constant stream of "twi_start()434 - [i2c0] START can't sendout!" It's filling kern.log, messages, and syslog at fast rate.

Google shows it may have something to do with 12c0 but I haven't touched that. :(

Any fresh ideas?

Thanks!!
jake
Posts: 10
Joined: Mon Feb 27, 2017 1:58 am

Re: v151 flooding twi_start()434 - [i2c0] START can't sendou

Post by jake »

UPDATE

OK, I restored my last good backup which rolled me back to v1.50

I then updated to v1.51 and checked the logs again. I'm still "twi_start()434 - [i2c0] START can't sendout!" messages, but less than 100 or so :roll: early in boot process.

There's two occurrences and then they seem to be gone after that.

The first starts following:
kernel: [ 1.321329] i2c /dev entries driver
kernel: [ 1.322404] sunxi cedar version 0.1
kernel: [ 1.322494] [cedar]: install start!!!
kernel: [ 1.322878] [cedar]: install end!!!
kernel: [ 1.323216] twi_start()434 - [i2c0] START can't sendout!

One difference I noticed was the [i2c0] section now increments every 25~27 or so messages; [i2c0], [i2c1], [i2c2].

The last occurrences, totalling only 9, follows:
kernel: [ 6.739784] g_serial gadget: Gadget Serial v2.4
kernel: [ 6.739817] g_serial gadget: g_serial ready
kernel: [ 9.620838] twi_start()434 - [i2c0] START can't sendout!

Anyway, it's up and it's stable.

Anyone have any idea what this is?
Post Reply