problem SSL activating for owncloud

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
soletto

problem SSL activating for owncloud

Post by soletto »

Hy i have a problem to activate ssl on my xu4.
I used this
Create key:

Code: Select all
mkdir -p /etc/apache2/ssl
openssl req -x509 -nodes -days 1000 -newkey rsa:2048 -keyout /etc/apache2/ssl/apache.key -out /etc/apache2/ssl/apache.crt


Enable SSL config and restart Apache:

Code: Select all
chmod 600 /etc/apache2/ssl/*
cat << _EOF_ > /etc/apache2/sites-enabled/default-ssl.conf
<IfModule mod_ssl.c>
<VirtualHost _default_:443>
ServerAdmin webmaster@localhost
ServerName example.com:443
DocumentRoot /var/www

LogLevel error
ErrorLog ${APACHE_LOG_DIR}/error.log
#CustomLog ${APACHE_LOG_DIR}/access.log combined

SSLEngine on

I have an account on noip

soletto.ddns.net

and a fritzbox 3490. Activating noip there.
But when going on https://soletto.ddns.net/owncloud

Then standing url not found.

Plz help me
Thx
soletto

Re: problem SSL activating for owncloud

Post by soletto »

changed in default-ssl.conf example.com to soletto.ddns.net

so i deactivated https acess on my fritzbox. Now i get access but

Strict Transport security http header is not configured to least 15768000 seconds. For enhanced security we recommend enabling hsts as described

No memory cache has been configured

And Webdav over https is not working. Can someone help me plz
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: problem SSL activating for owncloud

Post by Fourdee »

soletto wrote:No memory cache has been configured
OPcache is enabled for LAMP on Jessie: http://192.168.0.100/apc.php

Appears Owncloud requires php5-apcu for memcaching:

Code: Select all

apt-get install php5-apcu
add the following to /var/www/owncloud/config/config.php :

Code: Select all

 'memcache.local' => '\OC\Memcache\APCu',
Restart services:

Code: Select all

dietpi-services restart
Memcache is now active.
The "Strict-Transport-Security" HTTP header is not configured to least "15768000" seconds. For enhanced security we recommend enabling HSTS as described in our security tips.
If you require this level of security, follow their documentation:
https://doc.owncloud.org/server/8.1/adm ... t-security
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: problem SSL activating for owncloud

Post by Fourdee »

soletto wrote:Webdav over https is not working. Can someone help me plz
Have you enabled 443 port forwarding?
What webdav client are you using?
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: problem SSL activating for owncloud

Post by Fourdee »

I've updated the Owncloud documentation to allow for enabling the memcache: http://dietpi.com/phpbb/viewtopic.php?f=8&t=5&p=47#p47
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply