(little bug) RPi login script & LAMP install

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Deleted User 201

(little bug) RPi login script & LAMP install

Post by Deleted User 201 »

Hi,
I notice this 2 tittle bugs:

First small bug.
login
login
I think that "Default Login:" (red circle) should be seen only first boot and not forever.
And need to press ENTER to se "DietPi Login:"


Second small bug.
LAMP
LAMP
When I choose LAMP installer the script shows LASP (first red line) but installs correctly LAMP

Ciao!
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: (little bug) RPi login script & LAMP install

Post by Fourdee »

scx77 wrote:Hi,
I notice this 2 tittle bugs:

First small bug.
IMG_4367.JPG
I think that "Default Login:" (red circle) should be seen only first boot and not forever.
And need to press ENTER to se "DietPi Login:"


Second small bug.
IMG_4364.JPG
When I choose LAMP installer the script shows LASP (first red line) but installs correctly LAMP

Ciao!
Good finds, will look into it :)
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: (little bug) RPi login script & LAMP install

Post by Fourdee »

The second issue (incorrect description of LAMP when installing another stack) has been resolved for v102.

As for the 1st, this is run from rc.local. With systemd, it gets run as a new thread, rather than the system waiting for it to complete.
I'll have a look for another method we could use, to prevent it from overriding the original login prompt.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply