V149 fails to connect to internet

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
NTwoO
Posts: 15
Joined: Wed May 03, 2017 9:53 pm

V149 fails to connect to internet

Post by NTwoO »

Since updating to V149 on my RPi3 Internet access is down. I can access my Pi from the local network. Both ping and route produce seg faults if an internet url is requested. Pinging an internet IP address works. I guess I can edit my repositories to access the IP addresses to perform an update. Any ideas what might be causing this? My system also suffers from no networking if I do a warm reboot. cold reboot gets network access, though.
NTwoO
Posts: 15
Joined: Wed May 03, 2017 9:53 pm

Re: V149 fails to connect to internet

Post by NTwoO »

Changing the apt repos to IP addresses gets things working temporarily.
NTwoO
Posts: 15
Joined: Wed May 03, 2017 9:53 pm

Re: V149 fails to connect to internet

Post by NTwoO »

Going to static IP addresses and doing an apt update/upgrade has provided a solution for this problem.
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: V149 fails to connect to internet

Post by Fourdee »

NTwoO wrote:Any ideas what might be causing this? My system also suffers from no networking if I do a warm reboot. cold reboot gets network access, though.
Hi,

Most likely one of following:
- insufficient power supply (stable 5v 2A/2.5A, eg: official psu)
- Invalid/broken DHCP ack from router / failing router.
- Faulty LAN cable or HW failure on RPi3
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
NTwoO
Posts: 15
Joined: Wed May 03, 2017 9:53 pm

Re: V149 fails to connect to internet

Post by NTwoO »

Was none of the above. After running updates of the software via the static IP addresses hostname lookup is back to normal and warm start is working again.
NTwoO
Posts: 15
Joined: Wed May 03, 2017 9:53 pm

Re: V149 fails to connect to internet

Post by NTwoO »

It is a possibility that the shutdown hung without route/dns lookup available...
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: V149 fails to connect to internet

Post by Fourdee »

NTwoO wrote:It is a possibility that the shutdown hung without route/dns lookup available...
I believe your local network (most notably DNS), and its configuration is the issue here. Try resetting your router to defaults and run a fresh install of DietPi as DHCP.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
NTwoO
Posts: 15
Joined: Wed May 03, 2017 9:53 pm

Re: V149 fails to connect to internet

Post by NTwoO »

All is working flawlessly after updating the binaries on the Pi, so no worries further. The problem was solved when the binaries/libraries causing the seg fault was replaced. Not going to restart anything that is not running Windows before I know what the problem is :). Thanks in any case for the help and attention.
Post Reply