DietPi Installation process does not work any more?

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
sky59sky59
Posts: 27
Joined: Fri Jan 06, 2017 11:11 pm
Location: Ausria/Slovakia

DietPi Installation process does not work any more?

Post by sky59sky59 »

Yesterday I was fighting for few hours - I wanted to install HotSpot on OrangePi Zero using "optimized software" installation.

It said I have no internet (not true I could ping everything) or server is down.

Where is the problem? Is server really down?
User avatar
Fourdee
Site Admin
Posts: 2783
Joined: Tue Feb 06, 2007 1:36 pm

Re: DietPi Installation process does not work any more?

Post by Fourdee »

Hi,

What happens if you run the following commands?

Code: Select all

INTERNET_URL_TEST=$(cat /etc/apt/sources.list | grep -m1 'deb ' | awk '{print $2}')
/DietPi/dietpi/func/check_connection "$INTERNET_URL_TEST"
Please paste results if error. If no errors, should be good to go.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
sky59sky59
Posts: 27
Joined: Fri Jan 06, 2017 11:11 pm
Location: Ausria/Slovakia

Re: DietPi Installation process does not work any more?

Post by sky59sky59 »

root@DietPi:~#
root@DietPi:~#
root@DietPi:~#
root@DietPi:~#
root@DietPi:~# INTERNET_URL_TEST=$(cat /etc/apt/sources.list | grep -m1 'deb ' | awk '{print $2}')
root@DietPi:~# /DietPi/dietpi/func/check_connection "$INTERNET_URL_TEST"
[Info] Testing connection to http://ftp.debian.org/debian
[Info] Max duration of 20 seconds, please wait...
[Failed] Connection test | An issue has occured

root@DietPi:~#
sky59sky59
Posts: 27
Joined: Fri Jan 06, 2017 11:11 pm
Location: Ausria/Slovakia

Re: DietPi Installation process does not work any more?

Post by sky59sky59 »

root@DietPi:~#
root@DietPi:~#
root@DietPi:~# ping www.azet.sk
PING lb-home.s.etech.sk (91.235.52.77) 56(84) bytes of data.
64 bytes from 91-235-52-77.s.azet.sk (91.235.52.77): icmp_seq=1 ttl=240 time=44.7 ms
64 bytes from 91-235-52-77.s.azet.sk (91.235.52.77): icmp_seq=2 ttl=240 time=103 ms
64 bytes from 91-235-52-77.s.azet.sk (91.235.52.77): icmp_seq=3 ttl=240 time=103 ms
64 bytes from 91-235-52-77.s.azet.sk (91.235.52.77): icmp_seq=4 ttl=240 time=102 ms
64 bytes from 91-235-52-77.s.azet.sk (91.235.52.77): icmp_seq=5 ttl=240 time=102 ms
^C
--- lb-home.s.etech.sk ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4003ms
rtt min/avg/max/mdev = 44.790/91.461/103.904/23.346 ms
root@DietPi:~#
sky59sky59
Posts: 27
Joined: Fri Jan 06, 2017 11:11 pm
Location: Ausria/Slovakia

Re: DietPi Installation process does not work any more?

Post by sky59sky59 »

it seems a slash / is missing after debian? if I try it without slash even in mozilla it does not exist, but with / it opens "index of /debian"
sky59sky59
Posts: 27
Joined: Fri Jan 06, 2017 11:11 pm
Location: Ausria/Slovakia

Re: DietPi Installation process does not work any more?

Post by sky59sky59 »

after adding 3x slash it works? :

root@DietPi:~# ls
root@DietPi:~# pwd
/root
root@DietPi:~# cd ..
root@DietPi:/# cd etc/apt
root@DietPi:/etc/apt# ls
apt.conf.d sources.list trusted.gpg trusted.gpg.d
preferences.d sources.list.d trusted.gpg~
root@DietPi:/etc/apt# nano sources.list
root@DietPi:/etc/apt# INTERNET_URL_TEST=$(cat /etc/apt/sources.list | grep -m1 'deb ' | awk '{print $2}')
root@DietPi:/etc/apt# /DietPi/dietpi/func/check_connection "$INTERNET_URL_TEST"
[Info] Testing connection to http://ftp.debian.org/debian/
[Info] Max duration of 20 seconds, please wait...
[Ok] Connection test | Completed

root@DietPi:/etc/apt#
User avatar
Fourdee
Site Admin
Posts: 2783
Joined: Tue Feb 06, 2007 1:36 pm

Re: DietPi Installation process does not work any more?

Post by Fourdee »

sky59sky59 wrote:after adding 3x slash it works? :

root@DietPi:~# ls
root@DietPi:~# pwd
/root
root@DietPi:~# cd ..
root@DietPi:/# cd etc/apt
root@DietPi:/etc/apt# ls
apt.conf.d sources.list trusted.gpg trusted.gpg.d
preferences.d sources.list.d trusted.gpg~
root@DietPi:/etc/apt# nano sources.list
root@DietPi:/etc/apt# INTERNET_URL_TEST=$(cat /etc/apt/sources.list | grep -m1 'deb ' | awk '{print $2}')
root@DietPi:/etc/apt# /DietPi/dietpi/func/check_connection "$INTERNET_URL_TEST"
[Info] Testing connection to http://ftp.debian.org/debian/
[Info] Max duration of 20 seconds, please wait...
[Ok] Connection test | Completed

root@DietPi:/etc/apt#
Ah yes, seems you found the fix :)

This is a known issue with < v145 images. All our images have since been updated to v145 with the fix applied:
https://github.com/Fourdee/DietPi/issue ... -282374707
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply