Does the default Ampache installation include client APIs?

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
Mootch

Does the default Ampache installation include client APIs?

Post by Mootch »

I am interested in using a phone app for Ampache on my pi2, but haven't been able to get it to work after my initial attempts. Before digging into it further, I thought I would ask if clients are enabled by default or what's the best way to get them set up.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Does the default Ampache installation include client API

Post by Fourdee »

Mootch wrote:I am interested in using a phone app for Ampache on my pi2, but haven't been able to get it to work after my initial attempts. Before digging into it further, I thought I would ask if clients are enabled by default or what's the best way to get them set up.
Hi Mootch,

The following 3rd party API's are disabled:
- SubSonic
- Plex
- DAAP
- UPnP/DLNA
- WebDav

As DietPi installs v3.8.0, the Ampache API should be enabled by default. Assuming your phone app uses the Ampache API, this should work.
Please see here for information: https://github.com/ampache/ampache/wiki ... of-the-api
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Mootch

Re: Does the default Ampache installation include client API

Post by Mootch »

I tried a different app and it seems to be working. I was originally looking at a subsonic app, so I wasn't sure which APIs were enabled.

Thanks for the response.
simpledisaster

Re: Does the default Ampache installation include client API

Post by simpledisaster »

Hi everyone

I know I'm firing up an old thread here, but the issue stated is still very relevant to me!
Also I set up Ampache using the standard Dietpi installation and configuration. It works flawlessly so far when accessing and using it, however when trying to access Ampache using the Subsonic API (for instance using an iOS-App like "substreamer" or "avsub") it fails to deliver and can't connect (despite using the right connectivity data).
I switched on Subsonic API in settings, set up ACL's for all options. Currently I'm lost why it doesn't work.
The OP mentioned that he solved the issue without mentioning a solution.
I would be very thankful if this could be added!!

Any ideas why my configuration is not working? (Otherwise it's equivalent to OP's)

Thanks!
Post Reply