XU4 ethernet not found?

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
mims
Posts: 12
Joined: Wed Mar 15, 2017 7:52 am

XU4 ethernet not found?

Post by mims »

Hello,

I've installed the DietPi image on my Odroid XU4 eMMC.
It boots well but when I try to configure it (at first boot), I'm not able to configure the network.

The XU4 is connected on the Ethernet.
Each time I setup IP and press ok it asks me the same things.

I've quickly seen press pressing ESC key several time:
Nl180211 (or something like that) not found...

Could it be related to the Ethernet driver?
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: XU4 ethernet not found?

Post by Fourdee »

mims wrote:Hello,

I've installed the DietPi image on my Odroid XU4 eMMC.
It boots well but when I try to configure it (at first boot), I'm not able to configure the network.

The XU4 is connected on the Ethernet.
Each time I setup IP and press ok it asks me the same things.

I've quickly seen press pressing ESC key several time:
Nl180211 (or something like that) not found...

Could it be related to the Ethernet driver?
Hi,

Thanks for the report.

DietPi detects the active network adapter during boot.

We'll need to check status of the adapter, please paste results of the following commands (or picture):

Code: Select all

ifconfig -a

dmesg | grep eth

cat /DietPi/dietpi/.network
Also, to exclude any hardware related issues, which:
  • PSU used (eg: 5v/4A)
  • Odroid Cloudshell and drive, if used
Nl180211 warning is related to WiFi. DietPi disables all WiFi related modules to reduce memory consumption, when not in use. When DietPi runs commands to check status of network devices, thats when the warning will appear, although, its fine :)
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
mims
Posts: 12
Joined: Wed Mar 15, 2017 7:52 am

Re: XU4 ethernet not found?

Post by mims »

I reinstalled it and it's fine.

Solution: increase the size of the partition.

Thanks for the quick reply and sorry of making you losing your time.

PS: the OS seems awesome!
Post Reply