(resolved) Jessie - CurlFTPfs mount = emergency mode

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Jig

(resolved) Jessie - CurlFTPfs mount = emergency mode

Post by Jig »

I've been trying out DietPi today, and it just isn't working for me. Here's my process:

Code: Select all

Raspberry Pi 2, 4GB sd w/ v94, ethernet, 2a power supply

Login via SSH
Update to 97, reboot, wait 2 minutes
Login via SSH
USB drive: No, I'm setting this up with Ampache, media on NAS.
Optimized Software: VNC, LAMP, ProFTP
Boot Options: Yes, VNC
Additional Software: Curlftpfs
FTP Client setup now: Yes
Network Options: Static, correct addresses, Apply
Test Network: Online
FTP client: install curl
FTP client: setup, says connected, exit, back to Dietpi-Config
Overclocking: med
Locale: deselect en_gb, select en_us
Timezone: America>New York, exit
Go Start Install
During the Install process, setting locale fails, falls back to default (which shouldn't be an issue).
Set VNC password
Reboots, wait 10 minutes
Connection Refused w/ SSH and VNC
Once it reboots, it goes to emergency mode. Logging in starts an endless loop of echos stating it's copying to RAM. I let it sit for 40 minutes, with no luck. Please let me know what info you would like for diagnosis. Where is the log stored for the install process? Also, if you're in any IRC chatrooms please let me know; I think it would be easier to communicate efficiently there, assuming we were both present.
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: Emergency mode on boot

Post by Fourdee »

Hi Jig,

Thanks for the report and steps you made. It looks like a possible filesystem corruption or failure.

This kind of issue is caused by one of the following:
- SD card corruption.
The SD card is failing, or, a bad image write occurred.

- Unstable PSU
Regardless of amperage, the PSU must provide a constant and stable 5v output. You can check for this by looking for the rainbow square

- System instability
This can be caused by overclocking, or very rarely, faulty hardware on your device.

I would suggest trying a different SD card, and, no overclocking. Also remove any USB devices that draw excess power (eg: 2.5inch USB HDD). Try not to change any settings in dietpi-config (eg: leave DHCP). See if that works.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Jig

Re: Emergency mode on boot

Post by Jig »

I'll definitely mess around with it later when I'm back home. It wont be for another 8-10 hours, though.
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: Emergency mode on boot

Post by Fourdee »

Jig wrote:I'll definitely mess around with it later when I'm back home. It wont be for another 8-10 hours, though.
No worries Jig. Just let us know the results when you can.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Jig

Re: Emergency mode on boot

Post by Jig »

No sign of under-voltage or over-voltage. Nothing is connected other than the ethernet cable. Before I try a new SD (this is my smallest one, and I use my larger ones in my other Pi), I'll try again without overclocking or as much config changes. I'll report back once finished.
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: Emergency mode on boot

Post by Fourdee »

Jig wrote:No sign of under-voltage or over-voltage. Nothing is connected other than the ethernet cable. Before I try a new SD (this is my smallest one, and I use my larger ones in my other Pi), I'll try again without overclocking or as much config changes. I'll report back once finished.
Thanks Jig.
We just need to a get a baseline installation done with default settings. Then we should be able to debug this and find the cause.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Jig

Re: Emergency mode on boot

Post by Jig »

Trying from Linux this time, instead of Windows. Redownloaded the Jessie zip from the website. Wiped SD in GParted, flashed using dd. This time around I'm connecting a monitor to view what's happening. On first boot, there are some FAILED messages, however I could not see what they were. Still using SSH to configure. I used the same process as a did previously with these differences:

Code: Select all

I did not select anything in Additional software (curl should be installed with ProFTP, and if not, I can add it later).
The only changes I did in DietPi-Config were autoboot to VNC, and FTP Client (which installed curl).
During install, on main console, not SSH:

Code: Select all

systemd-fstab-generator: Failed to create mount unit file /run/systemd/generator/mnt-usb_1.mount, as it already exists. Duplicate entry in /etc/fstab? (This appeared a total of 6 times, before the display went black)
Same result :(

fstab:

Code: Select all

#Internal Drives---------------------------------------------------
proc            /proc           proc    defaults          0       0
/dev/mmcblk0p1  /boot           vfat    defaults,noatime  0       2
/dev/mmcblk0p2  /               ext4    defaults,noatime  0       1
tmpfs 			/tmp  			tmpfs 	noatime,nodev,nosuid,mode=1777  0 0
tmpfs 			/var/log 		tmpfs 	defaults,size=20m,noatime,nodev,nosuid,mode=1777  0 0
tmpfs 			/DietPi 		tmpfs 	defaults,size=10m,noatime,nodev,nosuid,mode=1777  0 0

#External Drives---------------------------------------------------
# - Try and use only ext4 for USB drives
# - Faster performance than NTFS, espically on RPi v1
/dev/sda1       /mnt/usb_1      ext4    defaults,noatime,nofail  0       0
/dev/sda1       /mnt/usb_1      ntfs-3g    defaults,nofail       0       0

#Samba Client------------------------------------------------------
#/mnt/samba . Please use dietpi-config and the networking menu to setup this mount

#FTP Client Mount--------------------------------------------------
curlftpfs#[user]:[password]@[server] /mnt/ftp_client fuse auto,allow_other,direct_io,transform_symlinks,user,uid=1000,nonempty 0  0
# a swapfile is not a swap partition, no line here
#   use  dphys-swapfile swap[on|off]  for that

I'm not sure why the External Drives are present. Regardless, I commented them out and it changed nothing.

Do you want me to try again without changing anything in DietPi-Config? I can always install/setup curl/ProFTP later, as well as VNC. Or just try my original process with a different SD?
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: Emergency mode on boot

Post by Fourdee »

systemd-fstab-generator: Failed to create mount unit file /run/systemd/generator/mnt-usb_1.mount, as it already exists. Duplicate entry in /etc/fstab? (This appeared a total of 6 times, before the display went black)
Gotta love SystemD.
This is nothing to worry about. As you can see from our /etc/fstab file, we use two mounting options for /dev/sda1. It basically ensures a NTFS or EXT4 formatted drive will be automatically mounted. It will try ext4 first, then ntfs. This will not effect your system, regardless of if you have a external drive or not. Its just SystemD saying "I dont think you should use Linux this way, so i'am going to tell you about it!" ;)

The failed message. Please try running this after boot, this will list any failed services. Let me know what it returns:

Code: Select all

systemctl status * | grep fail
Do you want me to try again without changing anything in DietPi-Config? I can always install/setup curl/ProFTP later, as well as VNC. Or just try my original process with a different SD?
Are you still being sent to Emergency mode?
Try another SD card if you can, just to be sure. Also, dont select, or install any software. Just run through the DietPi 1st run setup and select "go start install" when Dietpi-software appears.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Jig

Re: Emergency mode on boot

Post by Jig »

Fourdee wrote: Gotta love SystemD.
This is nothing to worry about. As you can see from our /etc/fstab file, we use two mounting options for /dev/sda1. It basically ensures a NTFS or EXT4 formatted drive will be automatically mounted. It will try ext4 first, then ntfs. This will not effect your system, regardless of if you have a external drive or not. Its just SystemD saying "I dont think you should use Linux this way, so i'am going to tell you about it!" ;)
Good to know, thank you!
Fourdee wrote: The failed message. Please try running this after boot, this will list any failed services. Let me know what it returns:

Code: Select all

systemctl status * | grep fail
Are you still being sent to Emergency mode?
Unfortunately I'm still in emergency mode, so I cannot do that.
Notable entries:

Code: Select all

Failed to mount /mnt/ftp_client.
Dependency failed for Local File Systems.
Fourdee wrote: Try another SD card if you can, just to be sure. Also, dont select, or install any software. Just run through the DietPi 1st run setup and select "go start install" when Dietpi-software appears.
Okay, I'll try another SD card, without any special selections. If that works, I'll report here and then try adding software one at a time.

Also, I'm on #dietpi on Freenode if you want to migrate there.

EDIT: Apparently, my other 2 SD cards are corrupt beyond repair. My working cards are already deployed and I'm unwilling to risk losing them. I'm going to try with this SD card again, without installing any software.
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: Emergency mode on boot

Post by Fourdee »

Jig wrote:Try another SD card if you can, just to be sure. Also, dont select, or install any software. Just run through the DietPi 1st run setup and select "go start install" when Dietpi-software appears.
Okay, I'll try another SD card, without any special selections. If that works, I'll report here and then try adding software one at a time.

Also, I'm on #dietpi on Freenode if you want to migrate there.

EDIT: Apparently, my other 2 SD cards are corrupt beyond repair. My working cards are already deployed and I'm unwilling to risk losing them. I'm going to try with this SD card again, without installing any software.
I'll join that IRC channel tomorrow as i'am off for the evening. This will also allow us to run some tests on your if needed.

I'am 99.9% certain that if you use a "tested and working" sd card, you wont be sent into emergency mode. What brand SD cards are you using? Sandisk never fail for me, yet, generic brands fail regularly.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply