C2 no sound over HDMI

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
PiOSFan
Posts: 12
Joined: Mon Dec 05, 2016 8:36 am

C2 no sound over HDMI

Post by PiOSFan »

Hi, I can't get sound out of the C2.
I tried http://dietpi.com/phpbb/viewtopic.php?f=9&t=48, but when trying to play a file, I get "sample format non available". Might be an issue with the downloaded wavs. Do you have a file that should work?
When trying

Code: Select all

amixer scet numid=3
the answer is: amixer: Cannot find the given element from control default.
Edit: HDMI cable and monitor work fine on Windows-PC and with Raspi 3.

Sent in Bug report. Ref code: 762aedbb-48f7-41dc-a4b2-7cc5ad4569ff-0

Thanks in advance-
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: C2 no sound over HDMI

Post by Fourdee »

PiOSFan wrote: Sent in Bug report. Ref code: 762aedbb-48f7-41dc-a4b2-7cc5ad4569ff-0

Thanks in advance-
Hi,

I'll check the bug report, thanks.

Can you test the following and see if sound works, paste results if error:

Code: Select all

speaker-test -c2
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
PiOSFan
Posts: 12
Joined: Mon Dec 05, 2016 8:36 am

Re: C2 no sound over HDMI

Post by PiOSFan »

Speaker test 1.0.28
Device is default
48000khz s16_le, 1 Channel
16 octaves
Range set to 48000
Buffer size 32768
Periods 4
Period size was 8192
Buffer size was 32768

0-Front left

Still no Sound


And idea?
Sorry, no copy-Paste of the result. Using my cell.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: C2 no sound over HDMI

Post by Fourdee »

PiOSFan wrote:Speaker test 1.0.28
Device is default
48000khz s16_le, 1 Channel
16 octaves
Range set to 48000
Buffer size 32768
Periods 4
Period size was 8192
Buffer size was 32768

0-Front left

Still no Sound


And idea?
Sorry, no copy-Paste of the result. Using my cell.
Looks like speaker-test is running fine. You should have sound.

Most likely HDMI cable or TV configuration. Try another HDMI cable, and TV if possible.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
PiOSFan
Posts: 12
Joined: Mon Dec 05, 2016 8:36 am

Re: C2 no sound over HDMI

Post by PiOSFan »

Hi Fourdee,

Thanks for your support. I double checked the cables and monitors. They work fine with Windows or my Raspberry.
I checked libreelec on a second SD card and Kodi gave the clicking sound :)
So I tried to install squeezelite and got the "you are offline, because debian is not available" message. So I changed to the UK-Location, installed squeezelite and updated to version 145.
Now the C2 is playing music from squeezebox or from my iPad :)

Don't know what really caused it.
Post Reply