[ODROID-C2] Disable Power Management - LXDE Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
PiDevices

[ODROID-C2] Disable Power Management - LXDE

Post by PiDevices »

Hello

I've installed the latest version of DietPi with Kodi, LXDE and Chromium to my ODroid-C2 with EMMC. It's running amazingly well so thanks for the effort you guys have put in to this software.

The only issue I have is that after 10 minutes of no use the screen goes blank and for some reason I cannot recover from it without using putty to connect and perform a reboot. I understand this is the screen saver / power management kicking in. Is there a way I can disable it?

When I've used LXDE previously it was a case of going to System > Preferences > Power Management through the desktop and disabling it but I'm guessing that as this is such a lightweight system that option isn't included, or at least I certainly cannot find it. How can I do it through command line?

Thanks in advance.

Martin
User avatar
Fourdee
Site Admin
Posts: 2782
Joined: Tue Feb 06, 2007 1:36 pm

Re: [ODROID-C2] Disable Power Management - LXDE

Post by Fourdee »

Hi Martin,

I believe it may be linked to: http://forum.odroid.com/viewtopic.php?f=52&t=2410

Can you try option 2 from the above link and let us know if this resolves the issue?

Add following to end of /etc/X11/xorg.conf :

Code: Select all

Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "BlankTime"  "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
EndSection
Reboot system and test.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
charger440
Posts: 3
Joined: Tue Nov 17, 2020 1:56 am

Re: [ODROID-C2] Disable Power Management - LXDE

Post by charger440 »

Hi,

I'm running DIETPI on a ROCK64 platform with LXDE. Runs great, LXDE is fast and easy to setup. I was however having the same problem with the screen blanking after 10 minutes. Ran through a number of tests including turning the screen saver off through xscreensaver, using "xset s off", "xset s 0 0", "xset s noblank", loading xfce-power-manager and disabling screen related options, etc. Your information on adding the ServerLayout0 section to /etc/X11/xorg.conf (had to create xorg.conf) was the only change that worked and saved some time from having to go through the LXDE code. Thanks!
User avatar
Joulinar
Posts: 2572
Joined: Sat Nov 16, 2019 12:49 am

Re: [ODROID-C2] Disable Power Management - LXDE

Post by Joulinar »

thx for sharing that this old solution is still working :)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply