Odroid C2 Installation Fails Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
LT401vette

Odroid C2 Installation Fails

Post by LT401vette »

I have an Odroid XU4 that I just installed Diet Pi on last week with no troubles.

Now I have a C2 that I am trying to set up the same way, except with eMMc instead of SD.

It boots fine with the image, down loads and unpacks.

I go through the menus for set, it does it's thing, but then screen goes blank and LED stops blinking.

I do see error messages related to a bad symbolic links that gets deleted. The link is referencing:

/lib/modules/3.1.14.79+/sources
and
/lib/modules/3.1.14.79+/build

I assume the binarys are already there so they don't matter.

After the screen goes out, it will no longer boot until I put the image back on it again.

Any debug info to look for?
LT401vette

Re: Odroid C2 Installation Fails

Post by LT401vette »

Interestingly... I tried installing to an SD card and it worked fine.
Not sure what's up. Perhaps I will try in making an image of the install and writing that to eMMC.
The only trouble is my SD card is 32GB and the eMMC is only 16, so I need to shrink an image to fit.
gnopy
Posts: 13
Joined: Fri Feb 03, 2017 9:54 am

Re: Odroid C2 Installation Fails

Post by gnopy »

Exactly the same problem for me. And from what I saw on other posts we're not alone.

I have an SD card that fits the size of my eMMC : 16gb.
So I did what you suggested : install clean on SD, then keep this image to write on eMMC.

It doesn't work. It doesn't get fooled by this technique. It boots until pages of errors and stall. Next time I reboot, nothing happens. Just like when you install directly on it.

It surely is a shame as eMMC is quite faster. Hope there'll be a fix soon enough.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Odroid C2 Installation Fails

Post by Fourdee »

gnopy wrote:It doesn't work. It doesn't get fooled by this technique. It boots until pages of errors and stall. Next time I reboot, nothing happens. Just like when you install directly on it.

It surely is a shame as eMMC is quite faster. Hope there'll be a fix soon enough.
Hi guys,

I run 8GB & 128GB EMMC's on the C2 with latest image. I'am yet to experience the issues you are describing.

Can you confirm which PSU's you are using for the C2?

Also, how are you writing the image to SD/EMMC? (eg: win32diskimager).

If you are using win32diskimager, please try formatting the SD/EMMC before writing the DietPi image, using this program with these settings:
- Format type = Quick
- Format size adjustment ON
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
gnopy
Posts: 13
Joined: Fri Feb 03, 2017 9:54 am

Re: Odroid C2 Installation Fails

Post by gnopy »

Hi,
I'm using v139 for the C2.
PSU: output : 5V / 2000ma. Bought on amazon.
I usually use my macbook to erase and format the card (forget why, but it's easier with disk tools). I format to fat just to get rid of the partitions.
Then I use win32diskimager on a pc to write the image on the EMMC (and/or SDCARD).

I will try with sdformater then, and let you know.
gnopy
Posts: 13
Joined: Fri Feb 03, 2017 9:54 am

Re: Odroid C2 Installation Fails

Post by gnopy »

I would add, the ubuntu release works like a charm on the eMMC.
But don't meet my needs (missing audio passthrough).
Not Dietpi.

:)
Zone

Re: Odroid C2 Installation Fails

Post by Zone »

I would recommend booting up C2 hooked up directly to a monitor for those that are running into a black screen or connection failed for SSH
dsfraser

Re: Odroid C2 Installation Fails

Post by dsfraser »

I had posted about this problem earlier. I had done a successful SDHC install but had the eMMC fail. Coping the /boot partition from the SDHC to the eMMC allowed it to boot one time. I could install other software and then it would fail on reboot. Just for heck of it, I re-copied the img to the eMMC and set the auto-install to true. I did this one as a headless install, just power and the network cable. Low and behold it succeed. I can ssh into the C2, something I could not do when I had it attached to a monitor. It is all very strange, but I now seem to have a functioning DietPi C2 running off of eMMC. I have installed OpenSSH, Samba, miniDNLA & MC. All good.
gnopy
Posts: 13
Joined: Fri Feb 03, 2017 9:54 am

Re: Odroid C2 Installation Fails

Post by gnopy »

hmm.

ok, so first I tried formatting differently with the SDformatter.
Then I tried what dsfraser said. Especially the "auto_install=1" in the dietpi.txt on the boot partition.

When rebooted, the screen went blank again.
I then copied a custom boot partition with boot.ini and dietpi.txt modified (screen resolution set to 0, and other options).
Then it booted correctly.
I had to install software again but everything is fine now.
Strange.
So there seems to be some sort of boot partition problem, in my opinion.
I''ll try to upload my boot partition and the img separately. I only installed MATE, Kodi, audio driver and screen resolution to 720p, for now.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Odroid C2 Installation Fails

Post by Fourdee »

gnopy wrote: I then copied a custom boot partition with boot.ini and dietpi.txt modified (screen resolution set to 0, and other options).
Then it booted correctly.
By this did you mean a simple copy the files in /boot, or, copy of the physical boot partition?

EDIT: Working on a new image, seems we had a corrupt 1st parition, will let you know when its ready for testing:
https://github.com/Fourdee/DietPi/issue ... -277533451
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply