RPi Zero hangs on boot

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
schojo
Posts: 9
Joined: Mon Jan 30, 2017 12:03 pm

RPi Zero hangs on boot

Post by schojo »

Hi all,
flashed DietPi_v142_RPi-armv6-(Jessie).img to my sd, edited some things in dietpi.txt.
autoinstall, swap size, wifi, openssh instead of dropbear and thats basically it.

setup starts, updates, reboots etc. - everything looks good but the last bit doesn't seem to work.
Stuck after cron and openssh started (successfully).

V144 RPi Zero (armv6l)

IP Address ...

Default Login:
Username = root
Password = dietpi

blinking cursor

:/
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: RPi Zero hangs on boot

Post by Fourdee »

schojo wrote:Hi all,
flashed DietPi_v142_RPi-armv6-(Jessie).img to my sd, edited some things in dietpi.txt.
autoinstall, swap size, wifi, openssh instead of dropbear and thats basically it.
Hi,

Thanks for the report, lemme see if I can replicate:
+ Wifi_Enabled=1
+ Wifi_KEY=xxxxxxxxxx
+ Swapfile_Size=0
+ AUTO_Install_Enable=1
+ AUTO_DietpiSoftware_SSHServerIndex=-2

Yep, looks like a bug with the new image, and, issues with firmware:
https://github.com/MichaIng/DietPi/issues/741

Images have been updated, should now be resolved:
Please re-download from https://dietpi.com/#download, then write the new image. Let us know if any issues.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
schojo
Posts: 9
Joined: Mon Jan 30, 2017 12:03 pm

Re: RPi Zero hangs on boot

Post by schojo »

+ Wifi_Enabled=1
+ Wifi_KEY=xxxxxxxxxx
+ Swapfile_Size=256
+ AUTO_Install_Enable=1
+ AUTO_DietpiSoftware_SSHServerIndex=-2

keyboard and wifi code set to DE

still hangs at the exact same spot. thought it was my wifi adapter but it connected and updated just fine.
schojo
Posts: 9
Joined: Mon Jan 30, 2017 12:03 pm

Re: RPi Zero hangs on boot

Post by schojo »

tried even less modifications with a usb to lan adapter. just swap to 256, keyboard to de, autoinstall 1
hangs at the very same spot. network works and did updates etc.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: RPi Zero hangs on boot

Post by Fourdee »

schojo wrote:tried even less modifications with a usb to lan adapter. just swap to 256, keyboard to de, autoinstall 1
hangs at the very same spot. network works and did updates etc.
Hi,

Can you try logging in at this point with keyboard attached, or, is the system hung completely? Does anything happen once logged in?

I believe this is simply the end of the automated installation and everything is ready for use.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
schojo
Posts: 9
Joined: Mon Jan 30, 2017 12:03 pm

Re: RPi Zero hangs on boot

Post by schojo »

okay, yeah that worked. when i press enter the prompt appears.
it still does but at least it connects to a lan before that so i can ssh.
Post Reply