Nanopi Neo: Audio not working

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
devnull

Nanopi Neo: Audio not working

Post by devnull »

Hi,
I tried to make the audio interface running on a nanopi neo with dietpi 142 but failed. You can select "default HDMI" or "H3-analogue" in dietpi-config but after rebooting no interface is present. An USB soundcard is working fine. Any hints?

Code: Select all

root@nanopi:~# aplay -l
aplay: device_list:268: keine Soundkarten gefunden ...

dmesg | grep -i audio
[    0.000000] Kernel command line: root=UUID=2ec38ad8-2e85-48dd-81dd-0526e76b5ebb rootwait rootfstype=ext4 console=tty1 console=ttyS0,115200 cgroup_enable=memory swapaccount=1 hdmi.audio=EDID:0 disp.screen0_output_mode=1920x1080p60 panic=10 consoleblank=0 enforcing=0 loglevel=1 ubootpart=779e1285-01   sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_fb_mem_reserve=16

root@nanopi:~# uname -a
Linux nanopi 4.9.0-sun8i #1 SMP Mon Dec 26 14:11:00 GMT 2016 armv7l GNU/Linux
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Nanopi Neo: Audio not working

Post by Fourdee »

Onboard audio is not currently supported in the 4.9 kernel. It is available in 4.10.
As we used ARMbian to build the initial image/kernel, we need to wait for them to switch to 4.10. Then we can re-create image.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply