OpenMediaVault Issues

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
buffalo0207
Posts: 34
Joined: Wed Sep 16, 2015 2:08 pm
Location: London

OpenMediaVault Issues

Post by buffalo0207 »

Hi,

I've literally spent hours trying to install OMV, but with no luck. After about 4 other attempts, my last attempt was a complete new and clean install of the DP software of v141 from the DP website and then only installing OMV after the automatically update. However, now that I've finally got OMV to install, when I go to 192.168.101.6 (that's the static address I have used for my Pi3 - my router is on 192.168.101.1 with other settings, like gateway address, on the Pi3 set accordingly), I get the 'Problem loading page' screen. I have even tried 192.168.0.100, and both addresses with http and https, but still with no luck.

Any thoughts?
User avatar
Fourdee
Site Admin
Posts: 2782
Joined: Tue Feb 06, 2007 1:36 pm

Re: OpenMediaVault Issues

Post by Fourdee »

buffalo0207 wrote:Hi,

I've literally spent hours trying to install OMV, but with no luck. After about 4 other attempts, my last attempt was a complete new and clean install of the DP software of v141 from the DP website and then only installing OMV after the automatically update. However, now that I've finally got OMV to install, when I go to 192.168.101.6 (that's the static address I have used for my Pi3 - my router is on 192.168.101.1 with other settings, like gateway address, on the Pi3 set accordingly), I get the 'Problem loading page' screen. I have even tried 192.168.0.100, and both addresses with http and https, but still with no luck.

Any thoughts?
Hi,

Lets see if basic web is working, and, we can access a basic page:
http://192.168.101.6/phpinfo.php

If that fails, please goto system and check status of Nginx:

Code: Select all

systemctl status nginx -l
And lets check OMV service aswell:

Code: Select all

systemctl status openmediavault-engined -l
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
buffalo0207
Posts: 34
Joined: Wed Sep 16, 2015 2:08 pm
Location: London

Re: OpenMediaVault Issues

Post by buffalo0207 »

Thanks Fourdee for getting back...

Using your options, I tried to see if the basic web is working and I still get the 'Problem Loading Page'.

To check the status of Nginx, I got the following ouput...

root@DietPi:~# systemctl status nginx -l
● nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; disabled)
Active: failed (Result: exit-code) since Thu 2017-01-19 16:11:29 UTC; 40s ago
Process: 17712 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=1/FAILURE)

Jan 19 16:11:29 DietPi nginx[17712]: nginx: [emerg] unexpected "e" in /etc/nginx/nginx.conf:4
Jan 19 16:11:29 DietPi nginx[17712]: nginx: configuration file /etc/nginx/nginx.conf test failed
Jan 19 16:11:29 DietPi systemd[1]: nginx.service: control process exited, code=exited status=1
Jan 19 16:11:29 DietPi systemd[1]: Failed to start A high performance web server and a reverse proxy server.
Jan 19 16:11:29 DietPi systemd[1]: Unit nginx.service entered failed state.


To check the status of OMV, I got the following...

root@DietPi:~# systemctl status openmediavault-engined -l
● openmediavault-engined.service - The OpenMediaVault engine daemon that processes the RPC request
Loaded: loaded (/lib/systemd/system/openmediavault-engined.service; disabled)
Active: active (running) since Sun 2017-01-15 13:57:47 UTC; 4 days ago
Main PID: 6218 (omv-engined)
CGroup: /system.slice/openmediavault-engined.service
└─6218 omv-engined

Jan 15 13:57:47 DietPi systemd[1]: openmediavault-engined.service: Supervising process 6218 which is not our child. We'll most likely not notice when it exits.
Jan 15 13:57:47 DietPi systemd[1]: Started The OpenMediaVault engine daemon that processes the RPC request.
Jan 15 13:58:02 DietPi systemd[1]: Started The OpenMediaVault engine daemon that processes the RPC request.


I hope this helps. Thanks again...
buffalo0207
Posts: 34
Joined: Wed Sep 16, 2015 2:08 pm
Location: London

Re: OpenMediaVault Issues

Post by buffalo0207 »

Hi Fourdee,

I noticed from the tests that nginx isn't working. It is installed.

Any idea how to get this working?
Post Reply