[resolved v142] alsamixer fails to load

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
User avatar
Sciamano
Posts: 264
Joined: Sat Oct 15, 2016 12:18 pm
Location: Italy

[resolved v142] alsamixer fails to load

Post by Sciamano »

Hello,
I seem not to be able to run alsamixer on any of my devices with dietpi.
I always receive the error:

Code: Select all

cannot open mixer: Invalid argument
This is really annoying, and to change my audio settings I had to fiddle with amixer, with the result that what would have been a 2 clicks task in alsamixer took me 15 minutes from the cli. :D

Will alsamixer ever work again in dietpi? :)
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: alsamixer again...

Post by Fourdee »

Sciamano wrote:Hello,
I seem not to be able to run alsamixer on any of my devices with dietpi.
I always receive the error:

Code: Select all

cannot open mixer: Invalid argument
Hi,

Thanks for report, i'll take a look and see if we can get this resolved: https://github.com/Fourdee/DietPi/issues/705
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
Sciamano
Posts: 264
Joined: Sat Oct 15, 2016 12:18 pm
Location: Italy

Re: alsamixer again...

Post by Sciamano »

Fourdee wrote:
Sciamano wrote:Hello,
I seem not to be able to run alsamixer on any of my devices with dietpi.
I always receive the error:

Code: Select all

cannot open mixer: Invalid argument
Hi,

Thanks for report, i'll take a look and see if we can get this resolved: https://github.com/Fourdee/DietPi/issues/705
That would be awesome! Thanks! :)
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: alsamixer again...

Post by Fourdee »

Alsamixer is fixed in DietPi v142 update.

In the mean time, you can fix this now, by removing the device line from ctl.!default {} in /etc/asound.conf

eg:

Code: Select all

pcm.!default {
    type hw
    card $SOUNDCARD_TARGET_CARD
    device $SOUNDCARD_TARGET_DEVICE
}
ctl.!default {
    type hw
    card $SOUNDCARD_TARGET_CARD
    #device $SOUNDCARD_TARGET_CARD # REMOVE THIS LINE
}
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
Sciamano
Posts: 264
Joined: Sat Oct 15, 2016 12:18 pm
Location: Italy

Re: alsamixer again...

Post by Sciamano »

Fourdee wrote:Alsamixer is fixed in DietPi v142 update.

In the mean time, you can fix this now, by removing the device line from ctl.!default {} in /etc/asound.conf

eg:

Code: Select all

pcm.!default {
    type hw
    card $SOUNDCARD_TARGET_CARD
    device $SOUNDCARD_TARGET_DEVICE
}
ctl.!default {
    type hw
    card $SOUNDCARD_TARGET_CARD
    #device $SOUNDCARD_TARGET_CARD # REMOVE THIS LINE
}
I've just tried this on my OPi PC, and it worked!
THANK YOU! THANK YOU! THANK YOU!
Post Reply