DietpiCam Error in RaspiMJPEG

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
TokoDude

DietpiCam Error in RaspiMJPEG

Post by TokoDude »

Hey i did an clean install on my RPi.
I installed dietpicam and set memory split to gaming (256MB video RAM)
But when i try to watch my camera i get the fallowing error:

DietpiCam Error in RaspiMJPEG
Restart RaspiMPJEg (./RPi_cam_Web_interface_installere.SH start) or the whole RPi.

the cabeling is done correctly.
Tryed 2 diffrent cameras (V2.1, V1.3)
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: DietpiCam Error in RaspiMJPEG

Post by Fourdee »

Hi,

Just completed a fresh write of DietPi and installation of DietPiCam. All working fine here on RPi 3, with v2.1.

Which version of DietPi are you running?

Try running Raspimjpeg manually to check for errors:

Code: Select all

raspimjpeg
On a working system, you should get:

Code: Select all

root@DietPi:~# raspimjpeg
start monitoring for pid: 1879
{2017/03/05 14:12:26} start monitoring for pid: 1879
RaspiMJPEG Version 5.7.06
recommended video buffer size 65536
h264 size set to 131072
recommended video buffers 1
h264 buffers set to recommended 1
Opening FIFO 0 /var/www/dietpicam/FIFO 7
MJPEG streaming, ready to receive commands
send smd 9
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
TokoDude

Re: DietpiCam Error in RaspiMJPEG

Post by TokoDude »

Rebooted and used both camera modules. (Cable works fine i think, the camera module 1.3 shows a red dot/light)
I'm getting this error:

root@DietPi:~# raspimjpeg
start monitoring for pid: 1699
{2017/03/05 14:54:29} start monitoring for pid: 1699
RaspiMJPEG Version 5.7.06
mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM)
mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
Error: Could not create camera
Executing macro /var/www/dietpicam/macros/error_hard.sh "Could not create camera"
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: DietpiCam Error in RaspiMJPEG

Post by Fourdee »

TokoDude wrote:Error: Could not create camera
If you are sure connection is correct (and orientation of cable)
- Camera failure (my v1.3 did this a few weeks back)
- Faulty ribbon cable

Reseat/connect sunny connector:
https://images-na.ssl-images-amazon.com ... SL256_.jpg

But lets check GPU memory split is actually applied aswell, run:

Code: Select all

vcgencmd get_mem arm && vcgencmd get_mem gpu
Must be 128MB or greater on GPU.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
TokoDude

Re: DietpiCam Error in RaspiMJPEG

Post by TokoDude »

hmmm well I tested it on 2 different pi's.
clean installations.
3 different ribbons and camera's
I reseat the connector at my camera V3
The memory split value's are right.

The problem is still there.
What else can i try?
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: DietpiCam Error in RaspiMJPEG

Post by Fourdee »

TokoDude wrote:hmmm well I tested it on 2 different pi's.
clean installations.
3 different ribbons and camera's
I reseat the connector at my camera V3
The memory split value's are right.

The problem is still there.
What else can i try?
Hi,

Let me check your config.txt. Probably easiest to send me a bug report, once done i'll take a look:
http://dietpi.com/phpbb/viewtopic.php?f=8&t=499#p2184
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply