[Software Suggestion] ElasticSearch

Suggestions for features and software you would like to see in DietPi, goes here.
Post Reply
beohna
Posts: 10
Joined: Mon Oct 25, 2021 2:51 pm

[Software Suggestion] ElasticSearch

Post by beohna »

Hey!

First I want to thank you for this wonderful piece of software that has been created here. Also for beginners, like my, it was possible to insatll my Raspberry Pi 4B with 4 GB RAM with Nextcloud. It works well, but I was suprised that Nextcloud has no full-text-search actived. To do so, you need to install ElasticSearch first to active the full-text-serach-Apps included in Nextcloud.
I try to install ElasticSearch, but it doesn't work . It's too tricky for beginners.
So it would be a wonderful, if DietPi would support ElasticSearch.

Please excuse my terrible English. It's very rusty over the years.

Greetings from Germany
beohna
User avatar
Joulinar
Posts: 6528
Joined: Sat Nov 16, 2019 12:49 am

Re: [Software Suggestion] ElasticSearch

Post by Joulinar »

Hi,

found this nice guide even in German https://www.c-rieger.de/volltextsuche-m ... tessaract/

But I'm not quite sure on the required JAVA version as they use JAVA8 on the guide attached. But this is quite an old version. On our latest Bullseye image we normally offer JAVA17 to be installed (if I'm not mistaken)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
beohna
Posts: 10
Joined: Mon Oct 25, 2021 2:51 pm

Re: [Software Suggestion] ElasticSearch

Post by beohna »

Yes this was one the tutorials I tried, but this doesn't work. First for the Java-Version, second the repository doesn't fit the arm-architecture, and so on....

Yes, dietpi uses openjdk-17-jre-headless.
User avatar
Joulinar
Posts: 6528
Joined: Sat Nov 16, 2019 12:49 am

Re: [Software Suggestion] ElasticSearch

Post by Joulinar »

ok Java should not be an issue. If I understood correctly, ElasticSearch is having it's own JAVA package that is shipped with main package

https://www.elastic.co/guide/en/elastic ... l#deb-repo

Anyway, looks like ElasticSearch is supporting 64bit only. Means you need the ARMv8 image.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
beohna
Posts: 10
Joined: Mon Oct 25, 2021 2:51 pm

Re: [Software Suggestion] ElasticSearch

Post by beohna »

Thanks for the hint.
Yes i use ARMv7 , but when I'm right "Nexcloud for Raspberry Pi" is only supporting the 32bit-Version..... so then Elasticseach makes no sense.
A little bit boring.
User avatar
Joulinar
Posts: 6528
Joined: Sat Nov 16, 2019 12:49 am

Re: [Software Suggestion] ElasticSearch

Post by Joulinar »

NextCloud can be installed on ARMv8 as well. There is no limitation.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply