user can't write to usb drive Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
droogi
Posts: 11
Joined: Tue Jan 05, 2021 6:52 pm

user can't write to usb drive

Post by droogi »

Hello Joulinar,
I mounted an exfat usb drive with the Drivemanager.
As root or dietpi I have write permission to it, but not as a user. I tried chmod 777 -R /mnt/128GB, did not work.
ls -lah gives drwxrwxr-x root: dietpi for /mnt/128GB.
I also unmounted, unplugged, rebooted, replugged and remounted the device.

Samba write is possible as dietpi, but not as user.
Nextcloud write access to this mounted device is not allowed.
In device manager read only is disabled.
I don't know what's wrong.
Regard, droogi
User avatar
Joulinar
Posts: 6458
Joined: Sat Nov 16, 2019 12:49 am

Re: user can't write to usb drive

Post by Joulinar »

issue is the exfat drive themselves. It did not allow any Linux permissions as exfat did not support it. If possible use an ext4 file system format or at least ntfs
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
rivkamears
Posts: 1
Joined: Mon Oct 11, 2021 5:09 am

Re: user can't write to usb drive

Post by rivkamears »

Ahh thank you, I had no idea that existed.
Post Reply