Mouse not Working with Pi 400 Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
mancity
Posts: 1
Joined: Tue May 25, 2021 9:57 am

Mouse not Working with Pi 400

Post by mancity »

Hi everyone,

Ive just run the install of DietPi on my Pi 400 (using the official USB mouse), whilst connected via ethernet for the updates and once rebooted, it loads up WinUEA as it should, but the mouse is not working. Any ideas? If it was any other mouse I would guess its not recognised and try another, but this is the official one, so id guess should work fine.


Thank you :)
vagabondivan
Posts: 2
Joined: Tue Jun 08, 2021 7:40 pm

Re: Mouse not Working with Pi 400

Post by vagabondivan »

Have the same issue, I have tried several mice, wired and wireless, Amiberry bootup quickly but mouse is not recognized until Amiga boot an .adf file ( only Amiberry GUI does not recognize any mouse ).

Did you solve this issue?
User avatar
MichaIng
Site Admin
Posts: 3529
Joined: Sat Nov 18, 2017 6:21 pm

Re: Mouse not Working with Pi 400

Post by MichaIng »

I think it's a bug with LibSDL2 v2.0.14: https://github.com/MichaIng/DietPi/issues/4457

Thanks for reminder, I'll check that now and create a binary to test, based on LibSDL2 v2.0.15 to see if it got fixed in the meantime. Else we'll need to downgrade to v2.0.12 :(.
vagabondivan
Posts: 2
Joined: Tue Jun 08, 2021 7:40 pm

Re: Mouse not Working with Pi 400

Post by vagabondivan »

LibSDL 2.0.15 solve the issue...tnx
User avatar
MichaIng
Site Admin
Posts: 3529
Joined: Sat Nov 18, 2017 6:21 pm

Re: Mouse not Working with Pi 400

Post by MichaIng »

I forgot to update you: All Amyberry builds have been updated in the meantime.
Post Reply