No Audio from USB DAC Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
Antod10
Posts: 15
Joined: Mon Dec 21, 2020 12:07 pm

No Audio from USB DAC

Post by Antod10 »

Hi! I'm trying to connect a Qudelix 5k USB DAC to my Pi4 running DietPi 6.34.3, LMS and SqueezeLite, but i get no sound from it.

I have tried to change the sound-card to usb-dac from audio settings but can't get it working
Antod10
Posts: 15
Joined: Mon Dec 21, 2020 12:07 pm

Re: No Audio from USB DAC

Post by Antod10 »

Any help please?
User avatar
MichaIng
Site Admin
Posts: 3097
Joined: Sat Nov 18, 2017 6:21 pm

Re: No Audio from USB DAC

Post by MichaIng »

Does the following show the DAC? aplay -l
And do you head something when running: speaker-test
Sometimes sound cards come muted by default, please have a look into alsamixer and raise sound levels or toggle mute switches.
Antod10
Posts: 15
Joined: Mon Dec 21, 2020 12:07 pm

Re: No Audio from USB DAC

Post by Antod10 »

1) Yes, it shows up
2) I got this messagges:
Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Sample format not available for playback: Invalid argument
Setting of hwparams failed: Invalid argument
3) Volume is fine

I saw that after choosing the card in dietpi-config and rebooting, LMS won't even start play the song
User avatar
MichaIng
Site Admin
Posts: 3097
Joined: Sat Nov 18, 2017 6:21 pm

Re: No Audio from USB DAC

Post by MichaIng »

Please try to enable the conversion plugin in dietpi-config > Audio Options.
Antod10
Posts: 15
Joined: Mon Dec 21, 2020 12:07 pm

Re: No Audio from USB DAC

Post by Antod10 »

Thanks, now works fine!
User avatar
MichaIng
Site Admin
Posts: 3097
Joined: Sat Nov 18, 2017 6:21 pm

Re: No Audio from USB DAC

Post by MichaIng »

Great to hear, so it was quite worth it to add this feature with last DietPi version 8).
Post Reply