NanoPi M4V2 randomly drops ethernet

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
bananawaffle
Posts: 2
Joined: Tue Sep 22, 2020 2:52 am

NanoPi M4V2 randomly drops ethernet

Post by bananawaffle »

Hi, I've been using Dietpi on NanoPi M4V2 for about 6 months or so. Mostly without any major issues until recently. I did a fresh reinstall with v6.32.2, and it randomly drops Ethernet connection. The device is not connectable or seen by my router, so I cannot SSH into it. The device stays on (with the red led on), and it runs fine (until it drops Ethernet again) after I do a manual power button restart.

I'm not sure what the problem is and how to diagnose the issue. I'm currently testing the command I have found on https://tadeubento.com/2019/nanopi-m4-r ... rk-issues/ to see if it solves anything.

Code: Select all

sudo ethtool -K eth0 rx off tx off
User avatar
MichaIng
Site Admin
Posts: 2423
Joined: Sat Nov 18, 2017 6:21 pm

Re: NanoPi M4V2 randomly drops ethernet

Post by MichaIng »

Which kernel do you run at? uname -a

The offload workaround was required on older kernel versions but should not on current ones 5.6 and up AFAIK.
bananawaffle
Posts: 2
Joined: Tue Sep 22, 2020 2:52 am

Re: NanoPi M4V2 randomly drops ethernet

Post by bananawaffle »

The Eth command didn’t solve the issue.

Uname -a shows

Code: Select all

Linux DietPi 5.8.10-rockchip64 #20.08.3 SMP PREEMPT Fri Sep 18 11:05:12 CEST 2020 aarch64 GNU/Linux
I ran dmesg -l err,crit,alert,emerg

and this came back

Code: Select all

[    2.540862] OF: graph: no port node found in /syscon@ff770000/usb2-phy@e450/otg-port
[    9.085288] rk_gmac-dwmac fe300000.ethernet: cannot get clock clk_mac_speed
[   54.219051] OF: graph: no port node found in /i2c@ff3d0000/typec-portc@22
[   54.515652] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4356-sdio for chip BCM4356/2
[   54.634998] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4356-sdio for chip BCM4356/2
[   54.648673] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4356/2 wl0: Mar  4 2020 22:06:08 version 7.35.349.87 (r724447 CY) FWID 01-c68a2890
User avatar
Joulinar
Posts: 2628
Joined: Sat Nov 16, 2019 12:49 am

Re: NanoPi M4V2 randomly drops ethernet

Post by Joulinar »

these messages are right after system startup

would be good to know what messages will be renegaded during eth0 dropping. Maybe it would make sense to switch to full logging to keep log files after system restart.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 2423
Joined: Sat Nov 18, 2017 6:21 pm

Re: NanoPi M4V2 randomly drops ethernet

Post by MichaIng »

BCM4356 is btw the WiFi adapter, so this is not related :?.
Post Reply