Z83-II and other Atom based devices

Suggestions for features and software you would like to see in DietPi, goes here.
kevinshane
Posts: 1
Joined: Wed Nov 15, 2017 3:23 pm

Re: Z83-II and other Atom based devices

Post by kevinshane » Wed Nov 15, 2017 3:28 pm

Hi, would u please add auto find the fastest mirror for dietpi x86 apt-get update command? I am trying to install the beta version, so far so good, however, the default ftp.debian.org is toooooo slow for me, it took around 1hour during apt get update(the os auto start updating and I can't modify the source list) :oops: please ... pretty please , thanks~
and btw, awesome job guys, please keep it going, thanks

Shane

n8xyn
Posts: 19
Joined: Thu Apr 21, 2016 12:04 am

Re: Z83-II and other Atom based devices

Post by n8xyn » Tue Nov 21, 2017 3:20 am

I've had mine up and running Transmission, Sickrage and openvpn 24/7 since this thread started without a single issue. I also installed Mate as an "incase" desktop. It's really very stable so far.

User avatar
johnvick
Legend
Posts: 643
Joined: Wed Jun 08, 2016 10:53 am
Location: New Zealand

Re: Z83-II and other Atom based devices

Post by johnvick » Tue Nov 21, 2017 4:45 am

Just got mine today but not allowed it until Dec 25th :)

User avatar
Fourdee
Site Admin
Posts: 2789
Joined: Tue Feb 06, 2007 12:36 pm

Re: Z83-II and other Atom based devices

Post by Fourdee » Tue Nov 21, 2017 6:29 pm

johnvick wrote:Just got mine today but not allowed it until Dec 25th :)
LOL :D
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.

Username
Posts: 6
Joined: Thu Jan 05, 2017 2:59 am

Re: Z83-II and other Atom based devices

Post by Username » Wed Aug 22, 2018 12:16 am

Hi, just installed dietpi on Beelink S2, but there is no audio support. Any update on when audio will be included in dietpi for beelink? thanks

User avatar
Fourdee
Site Admin
Posts: 2789
Joined: Tue Feb 06, 2007 12:36 pm

Re: Z83-II and other Atom based devices

Post by Fourdee » Fri Aug 24, 2018 8:47 pm

Username wrote:
Wed Aug 22, 2018 12:16 am
Hi, just installed dietpi on Beelink S2, but there is no audio support. Any update on when audio will be included in dietpi for beelink? thanks
Hi,

Very strange, on my Z83-II, audio support is working was setup in dietpi-config > audio:

Code: Select all

[email protected]:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: bytcrrt5651 [bytcr-rt5651], device 0: Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: bytcrrt5651 [bytcr-rt5651], device 1: Deep-Buffer Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audio [Intel HDMI/DP LPE Audio], device 0: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audio [Intel HDMI/DP LPE Audio], device 1: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audio [Intel HDMI/DP LPE Audio], device 2: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
it could be the beelink is using a non-standard audio chipset. Please can you paste results

Code: Select all

aplay -l
aplay -L
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.

Username
Posts: 6
Joined: Thu Jan 05, 2017 2:59 am

Re: Z83-II and other Atom based devices

Post by Username » Thu Aug 30, 2018 6:33 pm

[email protected]:~# aplay -l
aplay: device_list:270: no soundcards found...
[email protected]:~# aplay -L
null
Discard all samples (playback) or generate zero samples (capture)

This is the sound card that is installed per pciutils: lspci | grep "Audio"
00:0e.0 Audio device: Intel Corporation Device 3198 (rev 03)

kenhas
Posts: 1
Joined: Sat Oct 20, 2018 5:32 pm

Re: Z83-II and other Atom based devices

Post by kenhas » Sat Oct 20, 2018 5:40 pm

Anybody got wifi working on these devices? I think mine is a first generation thing and maybe wifi is not working with this model. This is the model I have: https://www.banggood.com/nl/Z83-Windows ... rehouse=CN

But no matter what i try, i can't get wifi to work. I don't see much questions about wifi with these boxes so I assume people got it working.

When i use dietpi-config, I get the message "Wifi must be enabled before settings can be changed", i press "Ok" and i get this: Image

User avatar
johnvick
Legend
Posts: 643
Joined: Wed Jun 08, 2016 10:53 am
Location: New Zealand

Re: Z83-II and other Atom based devices

Post by johnvick » Sat Oct 20, 2018 6:16 pm

I haven't been able to get it working but the hardware is capable as the wifi works on Windows on the same device.

John

User avatar
MichaIng
Legend
Posts: 1601
Joined: Sat Nov 18, 2017 5:21 pm

Re: Z83-II and other Atom based devices

Post by MichaIng » Sun Oct 21, 2018 10:51 am

@kenhas
It looks like Ethernet is listening to DHCP. Could you try to disable Ethernet first and enable WiFi afterwards?

Also you could try the current beta since we worked a bid on WiFi settings and general interface up/down on boot: https://github.com/Fourdee/DietPi/issues/2140

Post Reply