Page 1 of 1

Unbound 1.13.0

Posted: Sat Jan 23, 2021 7:54 pm
by Spy_64
Hello,

Currently running Pi-Hole with Unbound 1.9.0 that comes as part of the optimized installations on a Pi Zero W, but I was wondering if anyone had step by step instructions on how to compile 1.13.0 with the nghttp2 library for and upgrade the existing installation to benefit from the newly added HTTPS features. I have been able to find general conversations on this topic, but lacking the level of detail I would need to understand the procedure.

I have an older build of Cloudflared installed (2018 - newer builds fail to run) but am unaware of how to combine with Unbound - currently I have to use either one or the other and thought maybe the new version of Unbound might be a better solution.

Is Unbound with HTTPS being considered for v6.35? if so, has there been any mention of an estimated release timeframe?

Thanks,
Eric

Re: Unbound 1.13.0

Posted: Sat Jan 23, 2021 8:22 pm
by Joulinar
Hi,

DietPi themselves is not providing any software package. Usually they are installed from Debian apt repository. For Debian Buster, latest version of unbound is 1.9.0. A higher version, like 1.13, is available on Debian Bullseye https://packages.debian.org/search?suit ... ds=unbound

Re: Unbound 1.13.0

Posted: Sat Jan 23, 2021 9:06 pm
by Spy_64
Gotcha, makes sense. I thought there might be a distro compatibility component there, but wasn't positive how to verify. Thanks for the info.