RPi / minidlna / GMediaRender -> no video

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
xorkrus
Posts: 2
Joined: Tue May 28, 2019 5:12 am

RPi / minidlna / GMediaRender -> no video

Post by xorkrus » Tue May 28, 2019 6:56 pm

Hш. I want to make an network media player of RPi1. I read >10 instructions, did everything as said. Several times started on a new one. The result is one: my RPi1 plays only sound - like mp3 and any video. I could not find a gmedirander configuration file in DietPi. All that i was able to see in the log files is an error: "Error: XDG_RUNTIME_DIR not set in the environment." Through dieti_configuration, i tried to configure autologin to graphical mode, in console mode, without autologin - no result. Put the player omxplayer - also without result. How to make gmediarender play video?

xorkrus
Posts: 2
Joined: Tue May 28, 2019 5:12 am

Re: RPi / minidlna / GMediaRender -> no video

Post by xorkrus » Wed May 29, 2019 4:53 am

OK. Can someone tell me where in the DietPi is the configuration or the startup script?
[email protected]:/# find /|grep -i gmed
/usr/local/bin/gmediarender
/usr/local/share/gmediarender
/usr/local/share/gmediarender/grender-64x64.png
/usr/local/share/gmediarender/grender-128x128.png
[email protected]:/#
But...
[email protected]:/# ps ax|grep med
1072 ? Ss 0:00 /bin/dash -c gmediarender -u "813b5c7b-ec2c-441b-8f2e-0ade1c7e0ea7" -f "DietPi" --gstout-audiodevice=sysdefault --gstout-initial-volume-db=-1 --logfile=/var/log/gmrender.log -I "$(sed -n 4p /DietPi/dietpi/.network)"
1075 ? Sl 2:27 gmediarender -u 813b5c7b-ec2c-441b-8f2e-0ade1c7e0ea7 -f DietPi --gstout-audiodevice=sysdefault --gstout-initial-volume-db=-1 --logfile=/var/log/gmrender.log -I 192.168.1.179
[email protected]:/#

User avatar
MichaIng
Site Admin
Posts: 1871
Joined: Sat Nov 18, 2017 5:21 pm

Re: RPi / minidlna / GMediaRender -> no video

Post by MichaIng » Mon Jun 03, 2019 3:04 pm

@xorkrus
Many related files have gmrender in their name, which is why your grep pattern did not find everything.
The startup service is: /etc/systemd/system/gmrender.service

Where did you see the XDG_RUNTIME_DIR error? Just did a test install and whether journalctl nor /var/log/gmrender.log show this error.

However if it is really somehow related to your issue, then you can of course set it in the systemd unit, e.g.
Environment=XDG_RUNTIME_DIR=/home/gmrender

Post Reply