Page 1 of 1

How to install php7.3-dev

Posted: Mon May 13, 2019 11:03 pm
by baz123
I need to install the dev package for pecl and phpenmod. An apt-get fails.

Any suggestions?

Code: Select all

The following packages have unmet dependencies:
 php7.3-dev : Depends: libssl-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Re: How to install php7.3-dev

Posted: Thu May 16, 2019 1:29 am
by MichaIng
@baz123
Just fixed it with v6.24 hotfix (mainly for the critical issues with ARMv6). To fix now, run:

Code: Select all

echo -e '# libssl1.1 from sury.org breaks Lighttpd install
Package: openssl libssl*\nPin: origin packages.sury.org\nPin-Priority: -1' > /etc/apt/preferences.d/dietpi-openssl

Re: How to install php7.3-dev

Posted: Thu May 16, 2019 6:08 pm
by baz123
I am continually amazed at how responsive you are to these sorts of issues. Updated and all works. Many thanks.