[Solved] VMWare img on ESXI 6.5

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
3vwozv
Posts: 4
Joined: Fri May 19, 2017 8:57 pm

[Solved] VMWare img on ESXI 6.5

Post by 3vwozv » Sun May 28, 2017 3:38 pm

Could you update the VMware image so its compatible with ESXI 6.5 please? Currently on import when trying to edit it crashes and it won't start.

3vwozv
Posts: 4
Joined: Fri May 19, 2017 8:57 pm

Re: VMWare img on ESXI 6.5

Post by 3vwozv » Mon Jun 26, 2017 12:42 am

Was there any progress on this? Anything I can do to help troubleshoot/bug test?
thank you.

User avatar
Fourdee
Site Admin
Posts: 2789
Joined: Tue Feb 06, 2007 12:36 pm

Re: VMWare img on ESXI 6.5

Post by Fourdee » Tue Jun 27, 2017 5:49 pm

3vwozv wrote:Was there any progress on this? Anything I can do to help troubleshoot/bug test?
thank you.
Hi,

Is ESXI 6.5 not backwards compatible with VMware config and HW version 8 (ESXi 5.0)?

Code: Select all

config.version = "8"
virtualHW.version = "8"
If not, we'd need to update to HW version 13, but that will break < ESXi 6.5, and possibly VMware player/workstation:
https://docs.vmware.com/en/VMware-vSphe ... 7EBA0.html
This virtual machine (hardware version 8) is compatible with ESXi 5.0, ESXi 5.1, ESXi 5.5, ESXi 6.0, and ESXi 6.5.
Strange. Claims its compatible. Is your host ESXI system stable with other VM's?
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.

3vwozv
Posts: 4
Joined: Fri May 19, 2017 8:57 pm

Re: VMWare img on ESXI 6.5

Post by 3vwozv » Sat Jul 01, 2017 12:03 am

My ESXI install has been robust with everything else Ive thrown at it - something like 18 VMs across Windows, FreeBSD and some other Linux verisons. I'll dig into compatibility with ESXI 5 but given theres a workaround for this, I'd probably advise you stick where you are... I think... let me get back to you after Ive done some digging this weekend.

EDIT: The workaround was to import the dietpi install into Fusion 8.5, convert to a flat disk of 8GB and export that for import into ESXI 6.5 - that worked fine.

big_g_uk
Posts: 14
Joined: Sun Mar 18, 2018 4:06 pm

Re: VMWare img on ESXI 6.5

Post by big_g_uk » Mon Jan 14, 2019 1:54 am

Hi guys,

I have been struggling for days with this over Xmas. DietPi will not start full stop on my ESXi (6.7), so I have tried clean Raspbian and Debian 9 OS install and then run the script from the native OS. Will not work, for some reason DNS errors and so updates Debian, have no DNS issues.

If somebody is willing to help me get this working I am happy to create a tutorial either write-up or video.

Thanks

User avatar
MichaIng
Site Admin
Posts: 1728
Joined: Sat Nov 18, 2017 5:21 pm

Re: VMWare img on ESXI 6.5

Post by MichaIng » Tue Jan 15, 2019 5:23 pm

@big_g_uk
Thanks for your report.

Just to clarify:
- You installed fresh Debian image successfully and it works well, allowing APT upgrades and other web access without DNS errors?
- Then you ran DietPi-PREP to install DietPi on it?
- While DietPi-PREP is running you face DNS resolve errors, e.g. during the APT steps done within the script?
- Or did the DNS errors appear after the script has successfully finished and reboot done?

big_g_uk
Posts: 14
Joined: Sun Mar 18, 2018 4:06 pm

Re: VMWare img on ESXI 6.5

Post by big_g_uk » Mon Jan 21, 2019 11:43 am

Thanks MichaIng,

It was my DNS server causing the issue. All resolved now, and Debian 9 VM ran prep script without issue.

Much appreciate you support.

User avatar
MichaIng
Site Admin
Posts: 1728
Joined: Sat Nov 18, 2017 5:21 pm

Re: VMWare img on ESXI 6.5

Post by MichaIng » Mon Jan 21, 2019 2:52 pm

Great it works now and thanks for the reply :).

Post Reply