Page 1 of 1

Log Files

Posted: Thu Oct 29, 2015 5:28 pm
by bookedirl
Are the log files still under /var/log?

Everytime I check them they are always 0KB and have the current date as last modified.

I had a crash and was hoping to see what happened.

Re: Log Files

Posted: Fri Oct 30, 2015 9:05 am
by Pilovali
What type of log system do you have enabled?
By default DietPi logs into RAM, deletes it every hour and on reboot.

For more information, look here: viewtopic.php?p=68#p68

Re: Log Files

Posted: Fri Oct 30, 2015 7:36 pm
by bookedirl
Good question... Guess I did not know that dietpi was set up like that by default. How can I change this so any major system issues or crashes it would save to /var/log?

I have a Pi 2 set up with plex and randomly it crashes and I can't ssh or connect to plex through the browser. Since I can't connect to the pi through SSH it must be something related to the system, maybe network.. I'm not really sure.

Edit: Saw the link you posted. Thanks.

Re: Log Files

Posted: Fri Oct 30, 2015 7:44 pm
by bookedirl
I noticed my memory shows I've used up almost the whole gig... but top doesn't show that any programs that are taking up that much space. What would be taking up that much memory? Is it the logs?

http://imgur.com/OOgzPii

Re: Log Files

Posted: Fri Oct 30, 2015 8:20 pm
by Pilovali
Hello,

As viewtopic.php?p=68#p68 states, you can configure to save logs to /var/log the normal way.
Could you take a screenshot of 'htop'? Thanks.

About the crashing part, it could also be your power supply. Could you try an other power supply?

Re: Log Files

Posted: Fri Oct 30, 2015 8:30 pm
by Fourdee
bookedirl wrote:I noticed my memory shows I've used up almost the whole gig... but top doesn't show that any programs that are taking up that much space. What would be taking up that much memory? Is it the logs?

http://imgur.com/OOgzPii
Most of your RAM memory is cached. This doesn't mean your low on memory. Cached memory will be cleared to make room for programs that require active memory.

Try running this before top to clear your memory cache:

Code: Select all

free && sync && echo 3 > /proc/sys/vm/drop_caches && free
Also DietPi-Ramlog has a 20MB RAM limit:

Code: Select all

df -h | grep '/var/log'
Pilovali wrote:About the crashing part, it could also be your power supply. Could you try an other power supply?
Also, disable any overclocking.