PiHole Web Interface is not working

Having issues with your DietPi installation or found a bug? Post it here.
Caporeira
Posts: 24
Joined: Sat May 29, 2021 11:21 pm

PiHole Web Interface is not working

Post by Caporeira »

Hi,

After installing PiHole, web interface has worked.
But after restarting DietPi, wenn i want to open PiHole I'm getting follower error: 500 Internal Server Error

Why and how can I fix it?
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: PiHole Web Interface is not working

Post by Joulinar »

Hi,

which web server you are using?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Caporeira
Posts: 24
Joined: Sat May 29, 2021 11:21 pm

Re: PiHole Web Interface is not working

Post by Caporeira »

I'm using Lighttpd
But now I can't connect over SSH ☹️ - host is unreachable.
Last edited by Caporeira on Sat May 29, 2021 11:46 pm, edited 1 time in total.
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: PiHole Web Interface is not working

Post by Joulinar »

do you have a screen you can connect?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Caporeira
Posts: 24
Joined: Sat May 29, 2021 11:21 pm

Re: PiHole Web Interface is not working

Post by Caporeira »

I have three times rebooted my rp3 and now is working (PiHole).
But probably something with my PiHole setting is wrong.

Blocked queries and procent is 0.
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: PiHole Web Interface is not working

Post by Joulinar »

do you see Blocked entries in your Query Log?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Caporeira
Posts: 24
Joined: Sat May 29, 2021 11:21 pm

Re: PiHole Web Interface is not working

Post by Caporeira »

No, in Query Log I don't have any Blocked entries.
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: PiHole Web Interface is not working

Post by Joulinar »

but you see queries in general? Did you tried to open a web page with some ads on it? does it get blocked?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Caporeira
Posts: 24
Joined: Sat May 29, 2021 11:21 pm

Re: PiHole Web Interface is not working

Post by Caporeira »

Yes, in general I see the queries.

But very often: OK
(forwarded to localhost#5335)


I'm opening the web without ads and noting is blocked.
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: PiHole Web Interface is not working

Post by Joulinar »

Means technically ads are blocked by this is not displayed on web UI? Correct?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply