Page 1 of 1

Mouse or keyboard don't work on Kodi after fresh install

Posted: Tue Feb 16, 2021 1:35 pm
by tritrek
Hello, have installed Kodi via dietpi-software, it boots up nice but neither my mouse nor my keyboard works, Yatse and/or other remotes don't work either as I need to enable them first...but can't because I cannot control Kodi by anything... help please!

PS: Rpi2B, Kodi was working fine before, mouse and keyboard work on other devices, they also get power, I could see the registered but they don't move the cursor...

Re: Mouse or keyboard don't work on Kodi after fresh install

Posted: Tue Feb 16, 2021 1:38 pm
by tritrek
[ 1100.923768] logitech-djreceiver 0003:046D:C52B.0004: hiddev96,hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-3f980000.usb-1.3/input2

[ 1101.943153] logitech-hidpp-device 0003:046D:4003.0005: input,hidraw1: USB HID v1.11 Keyboard [Logitech K270] on usb-3f980000.usb-1.3/input2:2

[ 1102.069860] logitech-hidpp-device 0003:046D:406D.0006: input,hidraw2: USB HID v1.11 Mouse [Logitech M705] on usb-3f980000.usb-1.3/input2:3

[ 1104.486510] logitech-hidpp-device 0003:046D:4003.0005: HID++ 2.0 device connected.

[ 1974.232038] logitech-djreceiver 0003:046D:C534.0008: hidraw0: USB HID v1.11 Keyboard [Logitech USB Receiver] on usb-3f980000.usb-1.3/input0

[ 1974.310516] logitech-djreceiver 0003:046D:C534.0009: hiddev96,hidraw1: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-3f980000.usb-1.3/input1

[ 1974.394582] logitech-djreceiver 0003:046D:C534.0009: device of type eQUAD nano Lite (0x0a) connected on slot 2

[ 1974.419994] logitech-hidpp-device 0003:046D:4054.000A: input,hidraw2: USB HID v1.11 Mouse [Logitech Wireless Mouse] on usb-3f980000.usb-1.3/input1:2

[ 1976.042588] logitech-hidpp-device 0003:046D:4054.000A: HID++ 4.5 device connected.

Re: Mouse or keyboard don't work on Kodi after fresh install

Posted: Sat Mar 06, 2021 6:36 pm
by kobberholm
Hi!
I had the same issue and it took me a while to figure out the solution.
The problem is simply, that the default user (dietpi) is not in the group "input".

To add the user to the input group, run the command as root:

Code: Select all

usermod -a -G input dietpi
Now reboot and it should work :)